PDA

View Full Version : Radio signal


Bill-SD
07-14-2005, 11:36 AM
I have an '03 540i with Nav and DSP. When I change radio stations, there are several that take a long time to come in (10-20 seconds or more). I had the save problem on my E46 M3 with Nav, but different stations. They are not weak stations either. Once they finally come in, they are strong. Neither my other car or my gf's car have any trouble with the same stations. Any idea what would cause this to happen?

Thanks,
Bill

Terry Kennedy
07-14-2005, 11:52 AM
I have an '03 540i with Nav and DSP. When I change radio stations, there are several that take a long time to come in (10-20 seconds or more). I had the save problem on my E46 M3 with Nav, but different stations. They are not weak stations either. Once they finally come in, they are strong. Neither my other car or my gf's car have any trouble with the same stations. Any idea what would cause this to happenDo you have the feature that displays text (Station / Artist / Song) enabled? I've heard that some radios wait to receive the full message. Try turning it off and see if that helps.

randolphws
07-14-2005, 11:54 AM
I turned off the RDS and PTY on my 2002 X5 and the delays when changing stations went away.

I have a Navigation screen and I hit the right side of the MODE button to go into the split screen of radio display/current location - on that screen hit the INFO button and two boxes should come up for RDS and PTY and they will be checked. Use the right knob to select/deselect them.

Bill-SD
07-14-2005, 03:13 PM
Do you have the feature that displays text (Station / Artist / Song) enabled? I've heard that some radios wait to receive the full message. Try turning it off and see if that helps.

That was it! I guess I should have asked this question when I had my other car.

Thanks for the tip!!!