PDA

View Full Version : '06 X3 Sirius Radio install No Audio


Garyj
11-10-2005, 09:55 AM
I have '06 X3 with Navigation and Satellite Prep. I'm trying to install Sirius Satellite - BMW Part #65.12.0.398.140, which was removed from my trade-in. This receiver has one (1) antenna port. However, the Sat. Prep in my '06 X3 has 2-antenna leads -1 Blue & 1 Tan and neither fit this receiver. I shaved one of ridges on the receiver port enabling me to plug the Blue lead into the receiver. My problem is I have satellite reception - receiving channels and information, but I have no audio just some static. Do I need a different receiver that has 2 antenna ports or is there something wrong with the install? Is the Shark Fin the proper antenna or should reinstall the Terk mini antenna? Can anyone advise?
:) Thank you, Gary :)

ObD
11-10-2005, 11:14 AM
You are OK with the Sharkfin antenna .. though you could have just removed the keyed antenna connector instead of shaving off the receiver side. Not obvious how to remove it but it's really simple. Anyhow, IIRC that you need to rewire wiring/plugs in the center console to get Sirius. I think the rewire is all you need. Do a google on X3 Sirius install.

SRFast
11-10-2005, 11:16 AM
I have '06 X3 with Navigation and Satellite Prep. I'm trying to install Sirius Satellite - BMW Part #65.12.0.398.140, which was removed from my trade-in. This receiver has one (1) antenna port. However, the Sat. Prep in my '06 X3 has 2-antenna leads -1 Blue & 1 Tan and neither fit this receiver. I shaved one of ridges on the receiver port enabling me to plug the Blue lead into the receiver. My problem is I have satellite reception - receiving channels and information, but I have no audio just some static. Do I need a different receiver that has 2 antenna ports or is there something wrong with the install? Is the Shark Fin the proper antenna or should reinstall the Terk mini antenna? Can anyone advise?
:) Thank you, Gary :)

Gary,
Looks like you need to change a connector on the radio. Here is a link to help you: http://www.bmwmotorsports.org/pdf/x3_sirius_install.pdf

I live in NYC and willing to help you troubleshoot if you need the help. PM me if you need my help.

Regards...JL

Garyj
11-11-2005, 05:29 AM
Thanks JL,
I printed the instructions to swap the 12-pin connector located in the radio with the "CD-SDARS" 12- pin connector. I will give this a try.
Thanks, Gary :thumbup:

Garyj
11-14-2005, 09:07 AM
Thanks JL,
Switching the 12-pin connector behind the radio worked. Have audio thank you. Taking the radio out was relatively easy. First I removed the air vent register just above the radio by gently grabbing the top corners and pulling it out. Once removed you'll see 2 Phillips head screws that hold the face plate for the radio and climate control; I removed these screws then gently pop the face plate off. Then you'll see 2 Phillips head screws that secure the radio in place - removed these screws slide the radio out and switch the 12-pin connector.
Thanks again
GaryJ
:thumbup: :thumbup: :thumbup: