PDA

View Full Version : nav in an E46


kimhyeyun
12-23-2005, 12:17 AM
i want to put a navigation system in my 2001 330i. i don't have one right now, and i'd like to either put in the 2002 system or an aftermarket system, like an alpine. i'd like to know if anyone has done this (2001 with no nav to put in a 2002 or aftermarket system). I want to get an idea of cost, what it entils and how good it is. also, if anyone has any suggestions about whether the bmw or other manufacturer's nav systems are better. thank you!
-megan

esoteric
12-27-2005, 09:45 PM
it is pretty simple to do with an aftermarket unit if that is what you desire. The new alpine nav is very very good. I personally like the Zagat ratings guide on the restraunts. also you can mate it up to the IVA D310 and it is all touchscreen, further seperate the unit and flush the screen in the dash and the controls elsewhere. i have done a few of those lately.

If you wait a few months, i will let you in on a little secret, Alpine is going Bluetooth with their radios and will have some accys out to interface. but it will be months

Technic
12-28-2005, 06:56 AM
i want to put a navigation system in my 2001 330i. i don't have one right now, and i'd like to either put in the 2002 system or an aftermarket system, like an alpine. i'd like to know if anyone has done this (2001 with no nav to put in a 2002 or aftermarket system). I want to get an idea of cost, what it entils and how good it is. also, if anyone has any suggestions about whether the bmw or other manufacturer's nav systems are better. thank you!
-megan

Hi Megan

This is what you will need to do for an OEM Navigation System retrofit in your 2001 330i: http://forum.e46fanatics.com/showthread.php?t=203145

I did it over a year ago in my 2004 M3 and I am more than happy with the results and functionality; I do not think that you will find an OEM Nav kit for the price that I paid, though. All the details are in that link... :thumbup:

cambie
01-05-2006, 06:23 PM
I did this too in my 05 325i, with the help of Technic on this forum. Although I am fairly happy about my install, and would hate to not have it, i wouldn't really recommend anyone else do it. It costs way too much, and I wished dearly I had just pushed the saleman to find me a car with nav ready installed.

I still can't get mine to be very accurate. I'm not sure if i'm expecting too much from it, or it just is a crappy BMW implmentation of navigation. not having touch screen definately sucks. But i could deal with that if it was more accurate. It regularly shows me at a highway exit that I passed about 20 yards back...or it's built in guessing game will show me going on an exit ramp when i'm still on the highway. could be my metallic tint at 30%, but Technic has metallic tint as well.....so i'm still stuck. perhaps I've just got a bad computer.

Technic
01-06-2006, 03:27 PM
I did this too in my 05 325i, with the help of Technic on this forum. Although I am fairly happy about my install, and would hate to not have it, i wouldn't really recommend anyone else do it. It costs way too much, and I wished dearly I had just pushed the saleman to find me a car with nav ready installed.

I still can't get mine to be very accurate. I'm not sure if i'm expecting too much from it, or it just is a crappy BMW implmentation of navigation. not having touch screen definately sucks. But i could deal with that if it was more accurate. It regularly shows me at a highway exit that I passed about 20 yards back...or it's built in guessing game will show me going on an exit ramp when i'm still on the highway. could be my metallic tint at 30%, but Technic has metallic tint as well.....so i'm still stuck. perhaps I've just got a bad computer.

cambie... access tha Nav hidden menu and check how many Sat are locked and their S/N . That S/N will tell you if your tint or any obstruction is interferring with the signaling.

A S/N of 10-15 should be excellent reception on each locked Sat... less than that and maybe that's the problem.

cambie
01-06-2006, 07:17 PM
cambie... access tha Nav hidden menu and check how many Sat are locked and their S/N . That S/N will tell you if your tint or any obstruction is interferring with the signaling.

A S/N of 10-15 should be excellent reception on each locked Sat... less than that and maybe that's the problem.
I think i checked that previously when I had been working with you a little more one on one. I remember seeing that I got a view of enough satellites, but I don't remember seeing S/N info. I'll check it when I get home on Sunday. At the moment I'm still in LA enjoying the win over USC.

Anyway, I definately appreciate your help. Just wanted to make sure that was clear unless it came across another way.

Terry Kennedy
01-06-2006, 11:11 PM
I think i checked that previously when I had been working with you a little more one on one. I remember seeing that I got a view of enough satellites, but I don't remember seeing S/N info.It is in there:
http://www.tmk.com/bmw/6F5S0453-s.jpg

Technic
01-07-2006, 11:56 AM
I think i checked that previously when I had been working with you a little more one on one. I remember seeing that I got a view of enough satellites, but I don't remember seeing S/N info. I'll check it when I get home on Sunday. At the moment I'm still in LA enjoying the win over USC.

Anyway, I definately appreciate your help. [i]Just wanted to make sure that was clear unless it came across another way.[/b]

Absolutely not at all... keep enjoying your weekend, sir! :D

cambie
01-09-2006, 02:01 PM
back from my weekend, and I check the S/N ration....sure enough, only once did I see one of the satellites get a 10. 8 sats were visible, i was getting a signal from 7 of them, but my S/N was anywhere from 3.0 to 7 or 8.

I'm going to take a look at it after work today. It could well be the tint..I've got an extra gps antenna i bought with all of my other parts, so i'll plug it in and put it somewhere the tint isn't covering, and see if s/n improves. I'm conflicted...I hope this fixes the problem, but I don't want to retint my car :)

cambie
01-09-2006, 11:12 PM
hooked up the second antenna, and s/n improves greatly. i didn't drive around, but i would assume accuracy does too. i guess i need to relocate my antenna or retint.

Technic
01-10-2006, 10:40 AM
hooked up the second antenna, and s/n improves greatly. i didn't drive around, but i would assume accuracy does too. i guess i need to relocate my antenna or retint.

Damn, that's great! :thumbup:

harv
01-10-2006, 03:31 PM
Hi I have read quite a bit about sucessful nav retrofits, but cannot seem to find an up to date parts list including misc. brackets etc. needed for my install. I wish to have a wide screen, mark IV, and I think the business radio (AM/FM USA). I can't seem to source the retrofit harness either. Can anyone point me in the right direction?

Technic
01-10-2006, 05:28 PM
Hi I have read quite a bit about sucessful nav retrofits, but cannot seem to find an up to date parts list including misc. brackets etc. needed for my install. I wish to have a wide screen, mark IV, and I think the business radio (AM/FM USA). I can't seem to source the retrofit harness either. Can anyone point me in the right direction?

The harness is P/N 61 12 0 309 250... call Vaheh @ www.CrevierBMW.com for avilability and ordering.

Everything else is patience and eBay... :bigpimp:

cambie
01-13-2006, 01:13 PM
Damn, that's great! :thumbup:
I guess it's good to know that I'm getting a bad signal. I really don't want to mess with getting the window retinted though, and am not sure of anywhere else to mount the thing.

Here's the part that really gets to me though. I ordered a terk SIRI-Mini antenna to put on my car, got it last night, and for kicks, decided to see if it could get a decent signal on the rear deck inside the car (the BMW provided antenna wouldn't). Sure enough, it works like a champ, 30% metallic tint and all. I'm sure it's cutting down my reception, but it's acceptable...i haven't gotten many cutouts. I wish the nav antenna was as effecient.

jacobo
01-16-2006, 07:33 PM
Need some help with this installation, anyone out there that can help?

Here's the link to my scenario:

http://forum.e46fanatics.com/showthread.php?p=3806002&posted=1#post3806002