PDA

View Full Version : Sirius and Phatbox Ground Loop


TransHuman
01-01-2006, 06:10 AM
Hello all,

Just installed a Sirius reciever in my 04 M3. I already had the Phatbox. Once installed I started noticing a very bad ground loop problem on the Phatbox signal path. When I isolate each component, the ground loop doesn't exist only when I interconnect the Sirius box and the Phatbox.

Anyone experience this before? Any tips?

I've already tried running a different ground wire from the Phatbox to the common ground post found just behind the rear shock mount. It attenuated the noise a bit but did not remove it.

Thanks

el_duderino
01-01-2006, 01:36 PM
The VW forums also talk a lot about Phatbox engine noise, as I recall. Or maybe it was their user forum...

I assume that there is no RCA connectors anywhere in the PB harnessing? I would probably try to wire in a ground loop isolator with the connectors cut off.
OEM
The Acura TSX has a similar problem when the XM and an Icelink are connected at the same time. It also makes the XM sound like crap. Only fix I've found is to put relays on the L, R, and (-) outputs of the Icelink and physically disconnect the audio lines when using XM. You might be in a similar situation with the Phatbox.

TransHuman
01-01-2006, 03:00 PM
The VW forums also talk a lot about Phatbox engine noise, as I recall. Or maybe it was their user forum...

I assume that there is no RCA connectors anywhere in the PB harnessing? I would probably try to wire in a ground loop isolator with the connectors cut off.
OEM
The Acura TSX has a similar problem when the XM and an Icelink are connected at the same time. It also makes the XM sound like crap. Only fix I've found is to put relays on the L, R, and (-) outputs of the Icelink and physically disconnect the audio lines when using XM. You might be in a similar situation with the Phatbox.


Well thanks for the info. I have also seen the problems with the phatbox in VWs but I believe they make a specific version for VWs. My problem is that the phatbox is going through a specific blitzsafe adapter which converts from the phatbox din style connector to the traditional I-bus 2 cable setup. The phatbox does have the RCA connectors but I'm not using them.

I'm going to take a look at the ground on the Blitzsafe to see if I might have to unsolder the audio-ground as has been suggested in the other similar thread here. At this point I'm very frustrated because I had a great system with the Phatbox and now I have a dirty signal from that, and I'm less than enchanted with the high compression of the audio on the Sirius streams.

TransHuman
02-19-2006, 07:24 AM
Just an update. I ended up tracing the ground loop noise to the Sirius box itself. For the time (while it warms up here in MD) I ran some RG4 cable from the chassis of the sirius reciever to the common ground post near the HK Amp. It helps somewhat but it's not a solution. Still trying to decide if I even want to keep the damn thing!