PDA

View Full Version : Missing Sirius blue antenna connector


X3_driver
03-09-2007, 05:58 AM
Anyone know where the blue antenna connector is hiding in my 2007 X3 (like all of them, it "supposedly" has the Sat prep installed). The white one is there, but not the blue one.

FYI: I posted, without pics, my solution to removal of the non-nav, non-DSP, Business cd radio. It's really quite simple, only a screwdriver to another thread. Maybe they changed things for '07.

Thanks!

stangmatt66
03-09-2007, 07:52 AM
In many pre-wired X3's they were mis-wired. This is a known issue and your dealership should have a service bulletin about it. Take it in.

ViperNY
03-09-2007, 10:30 AM
Anyone know where the blue antenna connector is hiding in my 2007 X3 (like all of them, it "supposedly" has the Sat prep installed). The white one is there, but not the blue one.

FYI: I posted, without pics, my solution to removal of the non-nav, non-DSP, Business cd radio. It's really quite simple, only a screwdriver to another thread. Maybe they changed things for '07.

Thanks!

I seem to remember reading somewhere, not sure if it was this board but in the 2007 X3 there is no blue connector, you only use the white one.

Vipz

blueone
03-09-2007, 10:36 AM
i have a feb '07 x3...only had the white connector also...installed the sirius kit myself and it works fine with no issues

berbutler
03-09-2007, 03:38 PM
i have a feb '07 x3...only had the white connector also...installed the sirius kit myself and it works fine with no issues

It appears the current 07 X3's being delivered have the corrected the Sirius antenna wiring problem.

I took delivery of mine this week and the Sirius works fine without any rewiring.

BB