PDA

View Full Version : Data Transmission Error?


okiemark
03-15-2007, 08:01 PM
I searched my idrive on my 2005 545i for info about oil change. At 16000 mi it has not apparently indicated an oil change, and it says 4800 mls. On the Service Requirements tab, the message reads "Data Transmission Error 7/24/06." At 15,000 I took the car to the dealer and asked about the oil. We checked the dipstick, no oil used, and he checked the idrive and told me "Nope, not time yet." BUT, this just seems strange. Anyone know something about this message and the oil changing?

BMWNA
03-23-2007, 12:56 PM
I searched my idrive on my 2005 545i for info about oil change. At 16000 mi it has not apparently indicated an oil change, and it says 4800 mls. On the Service Requirements tab, the message reads "Data Transmission Error 7/24/06." At 15,000 I took the car to the dealer and asked about the oil. We checked the dipstick, no oil used, and he checked the idrive and told me "Nope, not time yet." BUT, this just seems strange. Anyone know something about this message and the oil changing?

I'm with BMW of North America, LLC. I've passed this message on to a BMW NA Customer Relations Representative who will be in touch with you soon.

okiemark
03-25-2007, 05:24 PM
I called my service rep, and they say the oil was changed last year. They don't know about "data transmission fault" but since the car seems to be in great shape, I will wait until 7/07 next scheduled service. I do wish they would have filled in the oil change in the service book, though. Thanks for the help.