PDA

View Full Version : 2007 X3 halts with left turn acceleration


firstbmwX3
03-19-2007, 08:36 AM
Hello, my 2007 X3 has halted when pressing on the gas to make a left turn. It has happened twice now. I wait for a break in traffic, step on the gas, get a little RPM and really brief acceleration then it just halts and nothing. This morning it did it halted again but started to accelerate and not a moment too soon. Anyway, I have an appt to have the Dealer check it out. Also, when I come to a full stop, I notice a ruff idle and slight vibration. The RPM needle looks like it hunts a little then settles down at about 800. It has only happened with left turns from a full stop. Any ideas or others having this problem. I know it isn't the quick shift into second gear, that feels completely different. Only premium gas used. Thanks for any insight.

JBasham
03-19-2007, 01:39 PM
Does it only happen when you're low on fuel? If so, I suspect a tank problem.

firstbmwX3
03-20-2007, 07:59 AM
No, it happened yesterday with over half tank. This morning the idle was rough enough that the whole vehicle was vibrating. It's cold herebut I keep in a garage. I'm sure they will figure it out when I take it in Saturday...

MJS
03-20-2007, 10:20 AM
Bad gas maybe? I'd run out this tank and fill it up at a top tier gas station, like Shell.

kataraika
03-20-2007, 12:38 PM
My mother used to have a similar problem with on old Jeep Cherokee, and it turned out to be a clogged fuel filter. Perhaps there were some debris in your new gas tank/lines that got swept into the filter?