PDA

View Full Version : fuel gauge


alejo honduras
06-14-2007, 11:59 AM
Hello people. I have a problem with my fuel gauge. It reads like a half and a little bit more, even when on empty. It never moves, only when I turn off the car. Is there anything to do with it? thanx a lot:thumbup:

Just Bryce
06-14-2007, 12:23 PM
Welcome to the club, my #1 E30 has the notorious erratic fuel guage, seems the newly purchased #2 is fully operational but only time will tell. It's a very common problem and an easy fix with a new sending unit installed under the back seat :thumbup:

lordofthewaters
06-14-2007, 04:39 PM
Yeah. What he said.

kishg
06-14-2007, 07:21 PM
i tried replacing the sender only to find it was the guage itself. it sort of works now, shows F when i fill up but seems to quickly drop after the half-way mark.

danielw05
06-15-2007, 02:39 PM
sounds exactly like mine...where is the sender and how much does it cost to replace?

kishg
06-15-2007, 06:13 PM
sounds exactly like mine...where is the sender and how much does it cost to replace?

it's under the rear seat. lift it up to access. cost around $80 new.

danielw05
10-11-2007, 02:06 PM
so I have tried twice now in the past couple of months to lift up the back seat..as you can tell I am in a huge hurry to fix this..:p...is there some kind of trick? do I just need to work out my arms for the next month and then try again?;)

maybe the previous owner used gorilla glue on it!!!;)

Just Bryce
10-13-2007, 07:13 AM
so I have tried twice now in the past couple of months to lift up the back seat..as you can tell I am in a huge hurry to fix this..:p...is there some kind of trick? do I just need to work out my arms for the next month and then try again?;)

maybe the previous owner used gorilla glue on it!!!;)

Use a bit of pressure from your knee while pulling up on the seat at the same time, should pop right up. On the passenger side you will see a black access cover. Take that off and you will see the lines coming off the pump assembly. There are four small nuts visable, 6mm I think, remove those and lift the sending unit straight up. :thumbup:

Soviet1942
10-13-2007, 08:47 AM
O_O Theres another fuel gauges under the seat? I don't understand the new sending unit installed under the seat ideal.
Mine works fine but gets a little crazy after it passes the half way mark.

omw41
10-13-2007, 12:22 PM
Also...it could be that the screws on the gauge itself are loose...look at the dash...look at the gauge...and you'll see the screws I mean...another common problem...

Paul Christian
10-14-2007, 10:37 PM
does your dash go crazy or just the gas gauge??if so it the SI batts.....to get sanding unit out was 2 mid sizes screw drives pust down and turn........

danielw05
10-15-2007, 07:33 AM
just the guage on mine...