PDA

View Full Version : Bluetooth Iphone problem, new module?


biserker1
07-28-2007, 02:33 PM
hey,

i just retrofitted a bluetooth kit in my car last summer (2003 325i). I think i have the 9th generation bluetooth module.

i have used motorolla and samsung phones with the kit without a problem. i got the iphone today and tried pairing it up.

the address book imports but the phone will not route the calls through the car.

does anyone know the issue?? Do i need to upgrade to the 11th generation bluetooth module??

thanks.

Technic
07-29-2007, 06:53 AM
hey,

i just retrofitted a bluetooth kit in my car last summer (2003 325i). I think i have the 9th generation bluetooth module.

i have used motorolla and samsung phones with the kit without a problem. i got the iphone today and tried pairing it up.

the address book imports but the phone will not route the calls through the car.

does anyone know the issue?? Do i need to upgrade to the 11th generation bluetooth module??

thanks.

Better wait until the iPhone gets some software update... you are not the only one having issues with the ULF and the iPhone, regardless of the ULF version. :confused:

biserker1
07-30-2007, 06:12 PM
I am going to test it on a 12th gen module....but i don't believe it will make a difference.

phastphil
10-15-2007, 08:05 AM
I did not see any newer posts on this subject, and wondered where it might have been moved to?

But, here's my experience:

3rd gen ULF in X5 worked OK with iPhone (paired, in/out connection reliable), although people said my audio was low and poor quality, I heard them great - OK for checking VM, Goog411 etc., but no one wanted to carry on a conversation for long.

Bought a 9th Gen ULF, now the iPhone pairs, but drops the pairing immediately upon an incoming or outgoing call. Voice quality is better on MOTO (V3 or V600) phones paired, but still not great.

I saw Bimmernav says a NEW improved microphone is available from BMW $55 that increases audio 6db (which is 4X in non techy terms) and has noise reduction built in. Might be worth trying unless someone here has tried it?

biserker1 wondering how your Gen12 test went ?

I've got $700 worth of ULF's, and could of bought a new one right off and could of solved the problem -

Some helpful info: I was told that Hardware revision above 13 and Software Revision above 85 or 90 (he wasn't sure) is the latest version, all earlier versions based on the same Hardware from 2004.

Technic
10-15-2007, 09:48 AM
I did not see any newer posts on this subject, and wondered where it might have been moved to?

But, here's my experience:

3rd gen ULF in X5 worked OK with iPhone (paired, in/out connection reliable), although people said my audio was low and poor quality, I heard them great - OK for checking VM, Goog411 etc., but no one wanted to carry on a conversation for long.

Bought a 9th Gen ULF, now the iPhone pairs, but drops the pairing immediately upon an incoming or outgoing call. Voice quality is better on MOTO (V3 or V600) phones paired, but still not great.

I saw Bimmernav says a NEW improved microphone is available from BMW $55 that increases audio 6db (which is 4X in non techy terms) and has noise reduction built in. Might be worth trying unless someone here has tried it?

biserker1 wondering how your Gen12 test went ?

I've got $700 worth of ULF's, and could of bought a new one right off and could of solved the problem -

Some helpful info: I was told that Hardware revision above 13 and Software Revision above 85 or 90 (he wasn't sure) is the latest version, all earlier versions based on the same Hardware from 2004.


It seems that ULF #13 is the one fully compatible with the iPhone...

phastphil
10-15-2007, 10:01 AM
Thanks - I'll check it out - might be worth the investment - and get rid of the stress caused by the earlier versions.

zerock
10-15-2007, 04:21 PM
it works on my 2006 X3. dont know the ULF number. Wifi needs to be off, for it to work properly.

phastphil
10-15-2007, 05:05 PM
Thanks for the update on ur X3, Bimmernav says the 13th gen ULF works with the iPhone $595 for the module alone - however for those following this thread, the later 2005/6 models use the Motorola version and iBus. The older models like mine need the standard ULF and apparently they are still making newer replacements. I'm waiting for a response from a guy at Visteon to confirm the Gen 13 compatibility.

pcbhz
10-25-2007, 08:18 AM
it works on my 2006 X3. dont know the ULF number. Wifi needs to be off, for it to work properly.


Zerock, mine is a X3 2006 3.0i +nav +blu +tv and my IPHONE doesn't work on it. It pairs, make calls but no sound in the speakers nor in the mic. Did you do anything particular to make it work ?

I've tried in a X5 and it was perfect ...

I would appreciate if you could help me. Maybe checking the ULF number to compare.

Tks