PDA

View Full Version : Problem with BMW iPod Integration Adapter


asawadude
07-29-2007, 02:17 AM
My wife recently purchased a CPO '04 BMW 330ci (E46). Upon taking the car home, we were pleased to discover an OEM iPod adapter in the glove box.

My wife has an older 4G iPod. I created BMW1... thru BMW5 playlists, plugged in the iPod, and it apparently worked fine.

But now my wife tells me that the OEM iPod adapter will play only the first 8 tracks of each playlist on her 4G iPod, then starts over with track 1. What's weird is that it will play about 2 seconds of track 9, then jump back to track 1.

When I plug in my 5G iPod Video, it works fine. I sync'd her playlists to my iPod and plugged it in. I can play every song on each of her 5 BMW playlists.

Apparently, it's a problem with her 4G iPod only. I checked the firmware - it's up to date (3.1.1).

Has anyone here ever heard of this problem? Is there a firmware update for the BMW iPod integration connector box?

AC88
07-29-2007, 05:59 AM
have you tried to re-fresh the playlist on your wife's iPod? i had no problem with my 4G iPod with the same firmware.

asawadude
07-30-2007, 02:07 PM
BMW1... through BMW5... were brand new playlists that I had just created on iTunes and freshly synced to my wife's 4G iPod.

tom @ eas
07-31-2007, 09:43 PM
My wife recently purchased a CPO '04 BMW 330ci (E46). Upon taking the car home, we were pleased to discover an OEM iPod adapter in the glove box.

My wife has an older 4G iPod. I created BMW1... thru BMW5 playlists, plugged in the iPod, and it apparently worked fine.

But now my wife tells me that the OEM iPod adapter will play only the first 8 tracks of each playlist on her 4G iPod, then starts over with track 1. What's weird is that it will play about 2 seconds of track 9, then jump back to track 1.

When I plug in my 5G iPod Video, it works fine. I sync'd her playlists to my iPod and plugged it in. I can play every song on each of her 5 BMW playlists.

Apparently, it's a problem with her 4G iPod only. I checked the firmware - it's up to date (3.1.1).

Has anyone here ever heard of this problem? Is there a firmware update for the BMW iPod integration connector box?

the BMW kit was never meant to be updated, there is either a problem with the kit or your wife's iPod. Have the iPod tested at a local Apple Store to rule out the iPod part of it, otherwise - have it upgraded to the DICE.

chrisproia
08-02-2007, 09:38 PM
Yeah, sounds like you need to hook you iPod to iTunes and give your songs an album name. see if that helps. Though it is somewhat tedious, it helped me when I couldn't play all the songs of a playlist on my iPod

tom @ eas
08-03-2007, 03:56 PM
Yeah, sounds like you need to hook you iPod to iTunes and give your songs an album name. see if that helps. Though it is somewhat tedious, it helped me when I couldn't play all the songs of a playlist on my iPod

This wouldn't help - the BMW-branded kit is not capable of text display, only the DICE.