PDA

View Full Version : E39 CD install question


theDynotuner
09-17-2007, 09:25 AM
I just purchased a CD\MP3 radio to replace the cassete unit in my 2000 528 iT. Althought the system works, it lacks a certain perfection in the following ways:

-steering wheel controls are no longer functional
-unit is always off when the car is restarted despite leaving it on when car turned off
-CD\radio\amp remain on for a very very long time after key is turned off. You cannot even turn it off manually since the display panel with the on\off switch has turned off.

Since the car was produced 09/99, I had to use the R17 to R40 adapter and the antenna adapter lead. The vendor I purchased it from also included the small 10 pin adapter that I have no provision for in my harness (looked extensively after reading a number of other posts). I do have the small coax cable (communication bus?) that now has no home on the new CD unit.

The cassette unit died some time ago, but did have steering wheel control at the time of its demise. The car has DSP and a Dension ICE Link Plus - both work fine except the steering wheel controls do nothing to navigate the iPod.

Does the communication bus for steering control go through the coax to the CD\head unit, or the display module? I've gone throught the diagnostic sequence and changed the button functions from off to man to af, etc. and still have no control over volume or channel selection.

I've seen others in the forum with similar issues, but couldn't pick out from responses which component to look at for my potential problem. It seems as though the CD unit is not my problem, but rather a control issue (?)

tom @ eas
09-17-2007, 09:40 AM
This is a very straightforward swap - try removing the battery cables for a short amount of time, reconnecting and see if this corrects itself.

theDynotuner
09-17-2007, 09:55 AM
Yeah, did that a couple of times. And once again just now. Still same result.

I also disconnected the ICE Link to see if that would make a difference. No change.

The failure of the original cassette was in that it would just not power up at all. Toward the end of its life, it would work intermittently - when it was 'on' all functions worked, when it failed to turn on, all was just blank - the display unit would show time\date and that was it.

How do the 2 head units differ in respect to their control functions. Has anyone on the board pugged in just the R40 and antenna and had full functionality? I'm curious as to what the other two connections do.

tom @ eas
09-17-2007, 10:51 AM
There might be a problem within the wiring or elsewhere (not related to the radio). Control functions between the 2 are 99% the same.

theDynotuner
09-17-2007, 11:30 AM
After searching the forum thouroughly, I agree that I proabably have an issue separate from the CD unit. I'm hoping someone on the forum can help narrow down the 'elsewhere' that I need to look. I don't know anyone with a similar e39 near me to test individual components in.

tom @ eas
09-17-2007, 12:21 PM
X5 would be compatible as well.