PDA

View Full Version : Engine overheats ('91 525i)


Lavalamp425
03-16-2003, 01:06 PM
Hi all,

Yesterday, I was driving north on I-5. I missed a shift (hit the gate between 3rd and 5th), but was back on the gas and over-revved it for a second or so. A few miles later, I got a "Coolant Temp" warning, so I pulled over and let the engine cool down for about 45 minutes. The temp was back to normal, so I started driving again. It overheated again within 3 minutes. I sat and waited again, then started driving. The temperature went up, so I pulled off before it even warned me this time. Called a tow, got to a service station, and filled up my coolant (which was admittedly low) and also topped off the oil. I also checked the hoses and belts and everything, nothing is wrong. I'm not leaking any fluids anywhere. At this point the engine was completely cool, so I drove it around the block, but sure enough the temperature went back up again. I got a tow home. I'm thinking that my thermostat may be stuck, but I'm wondering if anyone else has any ideas? Any help would be appreciated. Thanks!

Alex Baumann
03-16-2003, 01:11 PM
Hello and Welcome to the Board,

Check the article below. Although it's written for the 3.5 liter engines, it may help you to diagnose the problem

http://www.bmwe34.net/e34main/trouble/overheating.htm

Lavalamp425
03-16-2003, 07:43 PM
Thanks Alex. After reading that article and reading through the site some more, I think it may be my water pump. The pumps in these models have plastic impellers, and I still have the original one (127k miles); I'm surprised I haven't needed to replace it already. I'm having it looked at tomorrow morning, so hopefully I'll find out how bad it is then. Thanks again.