PDA

View Full Version : Service Indicators still on...


CarZar
11-27-2007, 11:32 AM
I took my 04 X5 to a dealer when the orange service indicator lit up......they told me its due for oil change and performed it under warranty........after the service i noticed that all four green indicators lit up (not orange).....is it normal? i was under impression that after the service, i will see only one green indicator on and after few thousand miles, second green light will come on and so on untill orange indicator come on suggesting it is due for service.

How do i know how far i am from next serive as next step will be orange light?

Please clear my confusion.

Thanks.

Zulu95
11-27-2007, 11:44 AM
You got it reversed. Starts with all the green leds and works down.

CarZar
11-27-2007, 12:46 PM
You got it reversed. Starts with all the green leds and works down.

Thanks for the reply, another question arises....

So it will work down till all the green lights are gone? and then when orange turns on, all green will turn on together? As at the time of service, all green and an orange was on.

motordavid
11-27-2007, 01:44 PM
They reset the indicator...thus, back to all green. As time/miles/gas consumption
and usage erode the green(s) down to service time again. Then, another reset.

It does not reset or go back to all green by itself.
GL,mD

Zulu95
11-27-2007, 02:09 PM
MD. LOVE the photos!!

motordavid
11-28-2007, 03:03 PM
OT...Thanks, Zulu.
Jes'snaps from our view off our deck in hillbillyheaven.
Great views, I push the button and it's like magic.
BR,mD

Zulu95
11-28-2007, 03:07 PM
Magic indeed. Keep them coming.
Sorry for stealing the thread everyone.