PDA

View Full Version : Service Maintanence Schedule


angina
12-24-2007, 11:30 AM
My 2007 X3 is at about 15,000 miles now, and I haven't had a service done on the car (oil change, etc) yet. I would have thought an engine CEL light would have gone off to prompt me to go in for service, but nothing yet.

What is the normal scheduled interval for the BMW free service? Will they replace windshield wipers by the way?

kjboyd
12-24-2007, 12:45 PM
yes, they will replace wipers... and when you first turn the car on, it should tell you how many miles left till you need service. 15k is about right for the first oil change.

bobbyjoe
12-25-2007, 08:52 AM
Mine doesn't show the "distance till service" by default, just the odometer, trip meter and whatever you select in the lower bank.

However, when I picked up my car and tried to get the tech to switch the odometer from miles to km, he tried without a computer by pressing key combos on the dash etc. He didn't manage to switch the odometer, but did get the "dist-till-service" up a couple of times.

Not sure the exact key sequence, but it seems like you have to press the "change display" button on the turn indicator stick and either the Set/Reset button or the button next to it at the same time. You have to press the two buttons while your car is "booting up" i.e. shortly after you turn the key from the off position to position I (car on, but engine not running).

I'll repost after I try it on my car, but I'm pretty sure it's something like what I said above.

Andrew*Debbie
12-25-2007, 09:50 AM
Mine doesn't show the "distance till service" by default, just the odometer, trip meter and whatever you select in the lower bank.



That isn't normal operation. It is possible your car is now set in a non-default mode.

Turn off the car, then turn the key to position 1. It should come on the display for a few seconds.

That is how I took the photo in my response to the duplicate of the original post.

http://www.bimmerfest.com/forums/showpost.php?p=2888139&postcount=2

bobbyjoe
12-25-2007, 12:29 PM
False alarm... and also faulty memory on my part.

If I turn the key to position 1, it will show the oil service (as Andrew*Debbie says). No need to press extra buttons. Starting the car shows the message briefly.

I did get into some other screen when I held on to "S/R" before turning the key to position 1. Whole bunch of numbers and the trip meter portion cycles through 1.0, 1.1, 1.2 etc. when I press the "S/R" button. Didn't muck around too much... didn't want to screw some setting up without knowing.