PDA

View Full Version : Radio Problem 2007-X3


NebraskaX3
02-19-2008, 12:59 PM
I may have put this in the wrong section earlier. I have a 2007 x-3 and the radio/cd player will sometime not play when I turn it on. This generally happens if it's been sitting for awhile and so far it just seems to be happening during the cold months. I had it to the BMW dealer a few times but it continues to occur. Anybody have any thoughts on what could be causing this?

Sonoman707
02-19-2008, 01:55 PM
Not sure of the cause. First step - they should swap out the head unit.

jamesbirkholz
02-19-2008, 02:19 PM
Nebraska

Did you ever use a "non-BMW-approved" Bluetooth phone? I accidentally linked mine after switching cell phones (it was defaulted to BT on). It totally funkified my radio - in fact - locked it up and for a week after it didn't work. At all.

Just a thought. Might not be your issue. Otherwise I agree - they might just need to replace the head unit.

Cheers

:thumbup:

x3ronnie
02-19-2008, 06:30 PM
Nebraska

Did you ever use a "non-BMW-approved" Bluetooth phone? I accidentally linked mine after switching cell phones (it was defaulted to BT on). It totally funkified my radio - in fact - locked it up and for a week after it didn't work. At all.

Just a thought. Might not be your issue. Otherwise I agree - they might just need to replace the head unit.

Cheers

:thumbup:

I'm using a "non-BMW approved bluetooth phone". So what!...This should not funkify the radio. Using a phone that's not on the list, should mean the phonebook doesn't load at worst. That's why I changed phones to my current one. If the issue is a bluetooth one, try unplugging the bluetooth module in the rear cargo area. My apologies for hijacking the thread, but I had to chime in on the bluetooth issue.

jamesbirkholz
02-21-2008, 02:32 PM
Ronnie

I asked BMW that specific question - that it worked but wouldn't load a phone book (big deal!). They said "don't use non-BMW approved period end". Apparently the software isn't as universal/Bluetooth-y as we'd all wish for :(

Mine worked flawlessly with the non-approved for 2-3 weeks w/o a phone book but then seized randomly :mad:

J

viii_ball
02-26-2008, 05:47 AM
I may have put this in the wrong section earlier. I have a 2007 x-3 and the radio/cd player will sometime not play when I turn it on. This generally happens if it's been sitting for awhile and so far it just seems to be happening during the cold months. I had it to the BMW dealer a few times but it continues to occur. Anybody have any thoughts on what could be causing this?

We have a 2008 X3 with a 9/07 build date that had the exact same problem. On morning start up the radio would not work yet anything else (CD, iPod) would work fine. This only occurred during first start-up. If you drove it for any length of time, shut the car off (i.e. stopping for gas) and turned it back on the radio would work fine. The dealer ended up doing a warranty swap.

Check your other options to see if they come on first thing and its just the radio.

infin8ly
02-28-2008, 07:32 PM
I had the same problem with the radio. BMW replaced the radio.

732002tii
02-29-2008, 08:31 AM
We had a similar problem on our X3. Our service department diagnosed it as the amplifier originall. The problem persisted and they replaced the head unit next, so far no further problems with the radio.

Now we have a new issue, that occurs only sometimes. You arrive at your destination and turn off the car. When you return and crank it up, the radio and a/c unit start up on a different channel and a different temperature setting. It's like a power interuption, but no memory loss. We've got to get the car back to the dealership for another look.

Garry