PDA

View Full Version : X5 bugs


Sean
04-25-2003, 09:37 PM
My folks were on their way to St. Simons, GA when the dash lit up like a Chirstmas tree. They called our dealer back home, said it's probably just a sensor, but take it to the nearest dealer to have it checked out. Luckly they were approx. 20 miles from the dealer in Savannah, GA . They hooked it up to the computer and learned it needs a new engine wiring harness, a big job according to my friend that's a BMW Tech. They put my parents in a 325i loaner and sent them on their way. :thumbup: The part apparently had to be VOR'ed (overnight) from Mt. Olive, NJ.

I certainly hope this is not a sign of things to come from this X5. I really had to push hard to get my father to buy another X5 after my brother totaled their other one while on vacation last year. This isn't a good start. :(

Emission
04-25-2003, 11:23 PM
Which model X5 (engine?), and how old is the thing?

Sean
04-26-2003, 12:32 AM
Originally posted by Emission
Which model X5 (engine?), and how old is the thing?

2002 3.0 (07/02 Build) Approx. 2500 miles

Sean
04-28-2003, 10:41 AM
Update: Apparently the X5 was delivered back to my folks last Saturday afternoon. Critz BMW in Savannah, GA sent a older gentleman to return it back to them and pick up the demo 325i. Very nice! :thumbup: Suppsedly everything is ok, we'll see.

alvinu
05-17-2005, 01:16 AM
i have an X5 lemon. the battery continualy goes dead and the dealer can't fix it. i feel like blowing it up it's been doing this on & off for 3 years, with no solutions. the guru at the dealership is stumped so even my local bmw repair guy has had it. hjope yours doesn't turn into a lemon.