PDA

View Full Version : new owner!


motohunter4
09-29-2008, 09:18 AM
hey guys, just aquired a 1991 535i for $400. body looks good and the interior is cherry. it does have some driveability issues ( hence the low price ) it idles too low ( 500 rpm ) which makes it stumble and it stalls and doesnt want to start afterwards. i did find the tube from the throttle body to the air meter has two rips in it, so i ordered a new one on ebay for $20. would this cause some of the problems?
thanks

motohunter4
09-29-2008, 11:21 AM
here are some pics

bimmer dot info
09-29-2008, 11:44 AM
The hose could help. Might also have some AFM issues. Change the hose and let us know if you are still having problems.

chemo64
09-29-2008, 03:28 PM
Wow! $400! Looks great. Can't wait to hear if the hose solves you troubles.

TIMSON
10-01-2008, 03:13 AM
sounds like thats your main problem but it would be worth checking all your other vacuum pipes and fittings and see how it goes, cheers

motohunter4
10-06-2008, 11:31 AM
got the hose in and its the wrong one. ive looked all over and cant seem to find the one i need online. it only has one hole for the check valve(not 2) that connects to the hose that goes to the intake. i cant find it anywhere? is there 2 different types of 3.5's in 1991?

TxAg98
10-06-2008, 11:42 AM
Im no expert, but I believe that 91's could either have the M30 engine or the M50, depending on month of manufacture.

motohunter4
10-06-2008, 12:20 PM
its the 3.5 liter inline 6 with single overhead cam

RocknRoll
10-06-2008, 01:03 PM
Probably the M30

CloudNine
10-07-2008, 08:22 AM
:rolleyes::eeps:

billygoat777
10-07-2008, 11:21 PM
535i only came with the M30