PDA

View Full Version : 535i rough idle at stop. Need help/advice!


method0075
11-17-2008, 02:08 PM
So my e34 1992 535i has been giving me a bit of a problem latley and I need advice. Things I have replaced
-plugs
-wires
-oil
-oil filter
-vacum line to FPR
-All six injectors

So my car runs great when I first start her up even at running temp I can sit in park rev it and not have an idle issue.

I will take it for a spin around the block and with every stop I make, the idle grows worse and worse. Eventually, as I take off after a few stops, the car will sputter/hestitate and then eventually begin firing in time.

I just checked fuel pressure and it is between 38 and 40 psi while running. It shoots up to 50-53 psi as I give it gas in nuetral (like reving it) and psi`s go back down as I take foot off the gas. It`s holding at 40 PSI when shut off as well. If I remove the FPR vacum line it shoots up to almost 55 PSI with no change in the vehicles idle; still rough.

Here is the odd thing the vehicle sounds to have a random miss fire here and there and every once in a while it will even idle smooth as new for a second or two. It will misfire and then get back on rythm. When I`m sitting in idle in park and I tap the gass to rev lightly, it will hesitate and then rev.

Please advise as I have just ordered a new FPR and fuel filter but am beggining to think my problem may be elctrical...

TxAg98
11-18-2008, 05:01 AM
My .02.....clean your idle control valve, replace your 02 sensor, and make sure the MAF is working. Those, plus a new fuel filter, cleared up my idle issue.

method0075
11-18-2008, 06:02 AM
Was your problem more pronounced at a stop after driving a bite?