PDA

View Full Version : I need your advice


bimmer1990
11-21-2008, 04:24 PM
I have a 1990 BMW 525i Series
the senario is that the engine light comes on only when i stop the vehicle
and when i drive the engine light goes away
also when i drive the car may shut off and on within a few seconds while i am driving
the car
what would be causing this situation?
I have changed the spark plugs recently

thank for your assistance

CJ74753
11-21-2008, 04:30 PM
How is the car running? Does it seem to have anything wrong with the way it sounds or feels when its idling or running? Was it doing this before you installed the new plugs?

bimmer1990
11-23-2008, 08:30 AM
thank you for your response

every morning I let the car warm up first and i notice the rpm idling goes up for a few seconds then maintains back to the resume idling position

as far as the driving it is good on while on the road and there is no engine noise

before install the plugs before the car would shut down and i would have to restart the engine

example this morning i drove the car for about 5 minutes to a stop sign and it shut off
but of course i did not let the car idle up for a few minutes

the engnie light came on at the stop sign and comes on when i let the car warm up

a few times on last week the car sort of shutoff but came back on in a few seconds while the car in motion

what maybe your thoughts on this
thanks

CJ74753
11-23-2008, 09:33 AM
Have you changed the fuel filter recently? It could be partially stopped up or maybe the fuel pump is getting weak. Have you done a stomp test to see if it has any error codes for the Check Engine Light? http://www.bmw4life.com/stompTest.htm Hope this helps

bimmer1990
11-23-2008, 05:16 PM
thank you cj

I have not replace the fuel filter or fuel pump

I will do the stomp test to check the error codes

I would like to let you know that I did not replace the wires

and i replace generic plugs not the platinum plugs

do you think this might be is what causing my dilemma

thanks

bimmer1990

CJ74753
11-23-2008, 05:46 PM
How long have you owned the car? Do you know when the last time the fuel filter was changed? As it could be stopped up from debris in the gas. As long as the plugs were the right ones for the car it should run fine. It sounds like its not getting enough gas or something, the boards seem to be awfully quite, I was hoping some others might chip in but those are my thoughts.

bimmer1990
11-23-2008, 06:06 PM
I did the stomp test but no errors codes followed the check engine light
check engine light still comes on
bimmer 1990
i have owned this car since may of this year

bimmer1990
11-23-2008, 06:08 PM
cj

thanks for your insightful advice

bimmer1990

CJ74753
11-23-2008, 08:04 PM
I found some more advice from http://www.bimmernut.com/forum/showthread.php?t=39527 which sounds about like your problem but they never replied and said if they fixed it. Hope this gives a little more insight :thumbup:

Check fuel pressure (culprits being FP Regulator, fuel pump and Idle control valve) in that order. Another thing to check for is the return valve on the fuel tank, maybe $15 USD from BMAparts.com.

And always look for vacuum leaks- you need to religously check and follow every hose and connection on the intake manifold: A vacuum leak on the FPR or elsewhere on an M50 can cause strange chaotic symptoms.

Get a new regulator if you are having problems and can't be 100% its the furl pump.

All that said, you need to check that a relay is not malfuncitoning when it or the car gets hot (completelty different things), so be sure to look for power a the fuel pump (on one of theose wonderful occasions that it won't start) and spark.

attack eagle
11-24-2008, 01:25 AM
I wonder if you don;t have two issues.

one a bad o2 and one a broken FPR vacuum hose.

bimmer1990
11-27-2008, 07:35 AM
Happy Holidays
Thank you all for your advice about my bimmer
Just to give you and update
Now the engine light remains on however the car is running okay with the engine light on
what precausation should I take while the car is running
I have had a car before with the engine on and it still was operating okay