PDA

View Full Version : E34 Serpentine Belt Replacement


ricks5series
12-05-2008, 02:03 PM
Hi gang,
New member here. Can anyone guide me to a DIY site on replacing my serpentine belts?

priceman14
12-05-2008, 02:27 PM
http://www.bmwe34.net/Wiki/tiki-index.php is a good DIY site, and it has belt pages under "general maintinance" and "engine" in the "maintenance" page

ricks5series
12-05-2008, 02:41 PM
Thanks for the link priceman but I didn't find anything in there about replacing the belts. I just need to know how to loosen the tensioners as it looks simply from there on, I hope!

priceman14
12-05-2008, 03:21 PM
the BENTLEY MANUAL will definitely help you with it, as it covers A LOT of DIY info (ill be getting one as soon as i buy my e34)

they aint exactly cheap but they're worth it as a lot of ppl here recomend them

you can get one from a lot of places but www.bavauto.com definitely has them, enter in year and model and it will be under manuals, good luck:thumbup:

bimmer dot info
12-08-2008, 07:26 AM
Pop the cover off part 7 and use an allen key to relieve the tension.
http://www.realoem.com/bmw/showparts.do?model=HD63&mospid=47404&btnr=11_1344&hg=11&fg=18

If you car does not have those tensioners you should have these.
http://www.realoem.com/bmw/showparts.do?model=HD63&mospid=47404&btnr=11_1399&hg=11&fg=18
Use a socket on a ratchet or a breaker bar to relieve the tension.

It is easiest to do this from the bottom.

ricks5series
12-09-2008, 07:29 PM
Thanks all, it was one of the easiest repairs I've ever done on this car. :)

danlau
08-28-2013, 06:34 PM
I wonder if you need to remove the fan and the fan shroud first before you replace the belts.

Thanks,
Dan Lau

ricks5series
08-28-2013, 07:13 PM
I wonder if you need to remove the fan and the fan shroud first before you replace the belts.

Thanks,
Dan Lau

Don't remember but don't think I had to. You do need to go in from the bottom though.

Monsignor
08-29-2013, 07:48 AM
I wonder if you need to remove the fan and the fan shroud first before you replace the belts.

Thanks,
Dan Lau

Makes it a world easier if you do.

I did mine when i did my w/p so it was off anyway, i dont recal if necessary

EDIT: yes you'd have to

danlau
08-30-2013, 06:29 PM
I guess I have to buy the tools to remove the fan then. Thank you for the advice.

Danlau

Dionte
09-04-2013, 12:10 PM
What brand belt did you end up going with? I plan on going conti-tech, i think thats the original belt they come with but Im not sure.

Monsignor
09-04-2013, 12:21 PM
I did conti-tech

Dionte
09-04-2013, 02:27 PM
I did conti-tech

Were you able to get yours at a store? Or did you have to order off the internet? I can't seem to find any local stores that have Conti-tech available.

Sent from my SGH-T839 using BimmerApp mobile app

Monsignor
09-04-2013, 02:44 PM
Were you able to get yours at a store? Or did you have to order off the internet? I can't seem to find any local stores that have Conti-tech available.

Sent from my SGH-T839 using BimmerApp mobile app

interwebzzz

danlau
09-04-2013, 06:59 PM
I use Conti-tech as well. I got it from the internet from Autohausaz.com. While installing the belt, I found out that the idle pulley was missing, and I am now waiting for the new pulley to arrive.

Dionte
09-04-2013, 08:37 PM
I use Conti-tech as well. I got it from the internet from Autohausaz.com. While installing the belt, I found out that the idle pulley was missing, and I am now waiting for the new pulley to arrive.

Wow they have great deals on autohausaz.com http://gyazo.com/187e6a2f5f9f10dcc4b9e08e89a9c098 probably what I'll be getting soon when i put my $20 on my card.

_Ethrty-Andy_
09-05-2013, 04:19 AM
I always use Contitech, Bosch, or Gates

Monsignor
09-05-2013, 07:21 AM
Gates in my Z. They're more performance oriented.

Dionte
09-14-2013, 11:30 PM
Got mine in yesterday. Just got them installed this morning with my grandfather. My old ones were dry rotting.

Sent from my SGH-T839 using BimmerApp mobile app

Arkansas finest
09-15-2013, 01:27 PM
im looking at mine right now and it looks BAD. tons of nicks are missing off the rubber. im scared to touch it actually, lol. ive had this car 8 months and no one said a thing. im looking into a new belt TODAY. thanks for bringing this to my attention.:thumbup: