PDA

View Full Version : Aternator trouble.


unicorn
06-26-2009, 05:01 PM
So I go camping, and run my car in the mountains of Tennessee, USA. Dragon Run, Route 129. A great run.
On the second day, the engine lost power, and engine eventually "dies". The alternator isn't charging the battery. So I get it towed to a garage, and the mechanic installs anew alternator and says it's charging at 13.8 amps. Cool, I drive off playing the radio, back to the campsite and I get 20 miles and engine lost power, and engine eventually "dies", again. Mechanic gets car back, installs another and the same thing happens. I towed it home and it sits in my garage. .:cry:

Now tell me. I have owned this car for 22 years, I replaced the alternator 2 times already... in 1989, and 1999.... Installing an alternator, it's plug and play. WTF :(

unicorn
06-27-2009, 03:42 PM
I fixed the alternator. Just like I remember, a plug and play device , that's the alternator. I guess, the mechanic overlooked a broken ground cable that I found. Probably broke it off when he took off the alternator. A common oversight.... rather dark down there... need a light stick.
It's the fat ground cable from the the engine to the back of the alternator (neg side). It broke at the metal circle crimped at the wire's end. A common oversight.... The BMW is easy to work on. Why would I get rid of this car? I love It!
Anyway, I be riding tonight. :thumbup:
http://i445.photobucket.com/albums/qq177/jpupster/IMG00259-20090425-1727.jpg

jhowe1
07-03-2009, 12:42 AM
A couple days late for me.
But, the same thing happened to me on my e21.
Some chaffed wires and caused a lot of headache from that alternator. And were hard to see also.
BTW, your e21 looks amazing!
Mine is begging for some work... I cannot bring myself to just get rid of it though.

dictator
07-25-2009, 03:51 PM
also get the battery tested. my alternator went out three times and it was partially because the battery was crap. mind you this was a fairly new battery (7 months or so) id also get that checked out.