PDA

View Full Version : my 1981 320i is having idleing issues and cold engine idle issues (i'm 16) plz help!


igardner
07-14-2009, 02:03 PM
hey guys im 16 are have recieved my dads bmw..(1981 320i) i have been working on the car with him for awhile and now im on my own for the most part doing work to it.....


no im really tight on money right now so im doing all the labor i can too it im really techincally smart (taking stuff apart and putting it back together fine and uinderstanding how it works) but cars is a new story to me for the most part

ANYWAYS


im having major idle issue including

spiking idling upon cold start about 2000rpm's
once warmed up a bit im getting major spiking and decreasing issue roughly 1250 rpm's +/-


i do have a manual that we got off bavarian autosport
HAYNES BMW 320I 1975 thru 1983
automotive repair manual


all the pictures and engine specs seem to not match up with my engine at all so i cant find half of the things i need to find


i have a spectre cone air filter system in the engine but i had idle issues previously with the air box as well im going to make the purchase soon of 4 prong spark plugs and a high performance wire set from bavarian

i also have a ansa exhaust on the car as well


if you can please help me out it would be much apperciated!!!

thank you
-ian gardner

I CAN GET PICS IF NEEDED OR IF YOU NEED ANYMORE INFORMATION ILL DO MY BEST TO FIND THE INFORMATION YOU NEED TO HELP ME!!

unicorn
07-18-2009, 05:24 PM
That is a vaccum leak, think air leak. It's a small air hose that has a crack. It's minor. Just need the air hose replace. Its a nuiscance at idle. When you ran it's ok. :thumbup:Is your oil cap on?

mattlass1981E21
11-11-2014, 12:00 AM
Can you post a picture of the air intake system and what are your thoughts on the exhaust?


Sent from BimmerApp mobile app

plummerd
11-14-2014, 12:59 PM
My 81 would not idle until it reached a certain running temperature and after reaching that temp. then it ran beautifully. There are other components that could be the issue. I'm just sharing my experience with the temp. switch. Good luck!!