PDA

View Full Version : Engine operating temperature


bcool
09-25-2009, 12:32 PM
I noticed my 750i takes about at least 10 minutes to get to normal operating temperature. Seems like about 7-10 miles before it reaches normal temp. Seems really long. Any comments?

asaseaban
09-25-2009, 12:40 PM
What is/are the weather temperature(s) that you've niticed this delay? Does it varies in the morning, afternoon, or evening?

bcool
09-25-2009, 02:30 PM
Seems the same whether morning/afternoon or evening. Hmmmm

asaseaban
09-25-2009, 05:42 PM
hmmmm...mine doesn't take that long but i know when i got the car around April and i was using the heater the car warm up faster compare to this time when i'm not using the heater.

When you start the car do you hear the engine rev a little higher and the drop (last a few seconds)?

bcool
09-26-2009, 01:07 AM
Yes the car does rev little higher and then drops. I timed how long it took today. It took the engine 15 minutes to get to normal operating temperature. Obviously this is not normal.
Can I ask you or anyone how long it takes for yours to get to normal operating temperature?
Thanks so much

kpumroy
10-16-2009, 03:29 AM
I have had my 750i for only 3 days. It does seem to take awhile to warm up but I noticed the temp gauge is for oil temp not coolant temp. Also my previous 550i didnt even have a temp gauge so I have little basis for comparison. This may be normal.

745ByMySide
10-18-2009, 12:25 PM
Oil temps will take longer to reach normal range.