PDA

View Full Version : Central locking/immobiliser issue


godwinson
10-06-2009, 03:16 AM
I recently bought a 1991 e34 525se, everything works great except a couple of things: Firstly when I press the central locking locking remote the locks "bounce" back instantly. To open the doors I then have to use the key in the drivers door, turn the key as far as it will go and then holding it there pull the handle and twist the key a fraction further which then opens the door. Locking the door works fine. When I first bought the car the driver's door wouldn't even stay closed when I shut it so a BMW specialist replaced the actuator which sorted that out but he couldn't work out why the locks bounced back.
Secondly once I am in the car I put the key in the ignition and have to press the button twice to deactivate the immobiliser. If I just press it once the car does not start and the alarm goes off. And by pressing the button of course all of the doors lock which means I have to manually pull the knob back up to unlock the car.
I appreciate these are small problems but it would be nice to have such a beautiful car working properly from a-z.
Any advice would be greatly appreciated.
Thanks in advance.

bimmer dot info
10-06-2009, 08:01 AM
The locks "bouncing" is typically caused by one of the locks not reporting that it closed properly.
The drivers door lock issue might be the root. It could also be frayed trunk wiring.

Can't really help you with the immobiliser issue.

ricknieves
10-06-2009, 03:04 PM
Maybe some made a copy of the key and never register the new key with the alarm module?