PDA

View Full Version : OBC Test Troubleshooting


ngruzevs
10-12-2009, 06:39 PM
I'm trying to troubleshoot a problem with my OBC and current fuel consumption in litres / 100 km. Within the Test menu on the OBC most of the tests function as intended including the tests below.

1 Display Test (all LCDs and LEDs activate)

3 Current Consumption in litres / hour

4 Average consumption (used in calculating range)

5 Current Range

6 Not used (this function is active on some, but not sure of the purpose)

7 Fuel Remaining in Tank (litres)

Test 2 I have a problem with, when selecting it and then driving the reading is always "0.0V BR", test 3 & 7 both report litres/hr and the remaining fuel in the tank. I assume because this test always reports 0.0V BR when pressing the "CONSUM" button I always get a zero reading.

http://home.iae.nl/users/bts/images/Func02.jpg

What is Test 2 measuring, it seems to be a voltage reading?

Any help would be appreciated.

woodnthings8
10-13-2009, 07:48 AM
Here are the functions

1) Activation of all Elements = Control of LEDs
2) Actual Consumption= Value which is available at time (Combined "T1" & V Signal)
3) Actual L/h Consumption= Value which is available at time (Instaneous)
4) RW Consumption (Averaged) = Value which is available at time Average witen last 30 miles
5) Range (Not Averageed)= Value which is available at time RW -Kilometers
6) Tank Volume = Value which is available at time signal from transmitter
7) Tank Volume (Determined)= Value which is available at time dampend with support values
8) Actual Speed= Value which is available at time digital speedometer
9) Operating Voltage (term 15)= Power supply in volts
11) Date ROM (TTMMJJ*)= When "ROM" was described (Manufacturing Date)

*TT= Day-Day
*MM=Month-Month
*JJ= Year-Year

Test 12-14 are for manufacturing purposes

woodnthings8
10-13-2009, 08:11 AM
Here is more info on the settings,

1 Display Test (all LCDs and LEDs activate)

2 Current Consumption in litres / 100 km

3 Current Consumption in litres / hour

4 Average consumption (used in calculating range)

5 Current Range

6 Not used (this function is active on some, but not sure of the purpose)

7 Fuel Remaining in Tank (litres)

8 Current speed (km/h)

9 System Voltage at Terminal R

10 Country / Language

11 Units / am.pm

12 Average speed (km/h) for calculating ETA

13 ETA

14 Date of software / mask of OBC

15 Production Diagnosis

16 Production Diagnosis

17 Display Vehicle Specific Data

18 Alarm Changeover (continuous vs. intermittent)

19 Lock / Unlock all functions (Sum of month and date to unlock or lock)

20 Correction Factor for OBC Fuel Consumption

21 Reset all defect codes, date and time

ngruzevs
10-13-2009, 03:50 PM
Thanks guys, I understand

Test 2 is based on Ti signal and road speed (or V)

The road speed on my E34 is inoperative (When I press the av speed button on the OBC I get 0. I have tried test 8 that also reads 0.0V.

My E34 can't calculate av speed therefore it also can't calculate fuel consumption L/100KM.

The OBC should get a voltage reading (for av speed) from the instrument cluster, I'm taking a guess that I've got a dodgy solder joint on the back of the instrument cluster.