PDA

View Full Version : Nav CD stuck in Sat Nav


RS2
09-15-2003, 04:22 PM
I was going to upgrade my Sat Nav but my Nav CD is stuck in the Sat Nav. Any ideas what to do? I have waited for the car to go into sleep mode and I have pulled fuse 7 and 41 and it sounds like the mechanism is trying to eject the CD when I push the button but nothing happens.

/RS2

CrazyBimmer
09-17-2003, 12:24 AM
I was going to upgrade my Sat Nav but my Nav CD is stuck in the Sat Nav. Any ideas what to do? I have waited for the car to go into sleep mode and I have pulled fuse 7 and 41 and it sounds like the mechanism is trying to eject the CD when I push the button but nothing happens.

/RS2

werid, i guess this is happening to a lot of people. Well for me i stuck another cd in there (halfway) to loosen the navi disc so it can come out.

RS2
09-17-2003, 02:58 AM
Well, eventually I manged to get the CD out with some help from members of another board.

The trick is to either wait for the car to go into sleep mode and then open the trunk quickly or pull fuse 7 and 41 and then promptly hold down the eject button on the Sat Nav unit until the light behind the button goes out (after about 3-5 min), release the eject button and then immediately press it again.

Fuse 7 and 41 will cut the power to the Sat Nav, Radio, CD Changer and Bord Monitor, but most of all the settings are still kept.

I really don't know what caused all this problem but I think the voltage may have been low since the car has been sitting in the garage for almost a week and the Sat Nav upgrade process won't start if the voltage is too low.

When I finally manage to eject the CD the Bord Monitor restarted with the old blue interface and without the Navigation menu (it restarted with the System Software in the Video module) so my only option was to try to upgrade the Sat Nav again.

But before I tried again I burned a new CD on another computer and drove around for awhile to recharge the battery. Then I did a new attempt... and the upgrade process started after a couple of minutes (very long minutes)... so now everything seems to be OK again!

And it turned out that the mechanical sound was coming from the CD Changer since I pulled the fuses...

Those damned electrical gremlins!

/RS2