PDA

View Full Version : cruise control advice needed


CrazyElmo
11-01-2009, 07:11 PM
I'm the original owner of a 1991 525i MT.

I've been having cruise control problems whereby the cruise seems to constantly hunt for the proper throttle position: brief surge, brief decel, surge, decel, etc. Worst when beginning to climb or descend a hill when a change in throttle position is called for.

I'm wondering if this sounds more like a problem with the CC module/computer vs the actuator (? or something else?).

Any thoughts will be greatly appreciated.

attack eagle
11-01-2009, 07:18 PM
or a partly contaminated rear diff sensor.

CrazyElmo
11-02-2009, 05:24 PM
Thanks for your input. I checked out a schematic and this looks like it would be a rather simple job (I doubt I'd even have to involve my brother-in-law).

If you don't mind, can you think of any other symptoms that would be more evidence of a bad differential sensor?

attack eagle
11-02-2009, 07:50 PM
funky speedo, but that s about it.

it might not be.

could also be the actuator not freely moving (or cable binding, or linkage sticking) as you surmised

CrazyElmo
11-04-2009, 07:04 AM
thanks

CrazyElmo
07-29-2010, 05:18 AM
:)funky speedo, but that s about it.

it might not be.

could also be the actuator not freely moving (or cable binding, or linkage sticking) as you surmised

Finally got around to doing something about my cruise control problem - the speedo did become funky prior to the intervention so I replaced the speed sensor.

Problems solved - and at a considerable savings over an actuator repair.

Thanks for your help.

BMR_LVR
07-29-2010, 05:37 AM
Bravo ! Thanks for letting us know. Glad it was something simple.