PDA

View Full Version : Transmission trouble


Baristaman77
11-09-2009, 09:52 PM
Ok heres what goin on my roommate has an e34 535i. He's too mechanically illiterate to figure this out so im trying to for him. His trans is doing some funky stuff. For a while it was going into the safe mode where overdrive wasn't working or something like that. Recently he lost reverse with no warning. So we got a trans ecu which fixed the safe mode but still no reverse as of yesterday. Today reverse works but its back in safe mode. Any ghost hunters out there?

Tourburgring
11-10-2009, 07:45 AM
#1 Check the Transmission Fluid Level - Low fluid can cause all kinds of odd behaviour.
#2 Take car to a BMW specialist, open your wallet and say "help yourself" !!!:cry:

Seriously though, these transmissions are not the most robust and are prone to failure at high mileages or if they have been abused.

Baristaman77
11-10-2009, 04:47 PM
Fluid level seems to be ok even though its tough to read those sticks. What i don't get is how reverse could be gone for so long and come back when i change the ecu. is there any sensors that could be the problem?

E36 Phantom
11-10-2009, 05:05 PM
I'd guess a solenoid is dying, but not quite dead yet. But, I've only owned one auto car and didn't bother familiarizing myself with the internals of the AT much.

Baristaman77
11-11-2009, 08:56 AM
Any idea where that solenoid would be located i wanna know where to look before i climb under there

E36 Phantom
11-11-2009, 10:56 AM
Any idea where that solenoid would be located i wanna know where to look before i climb under there

:rofl: Yeah, inside the transmission. You can find it after you drop the tranny from the car and break it open. That's about as specific as I can get for an AT.