PDA

View Full Version : heater blows hot then cold


royston
11-19-2009, 06:09 AM
on the motorway at 70ish the heater blows cold when you stop or drive slow it warms up.pollen filters were blocked now removed,thermostate has been replaced. engine temp stays dead half way on the gauge when warmed up and does not budge. it does not appear to be losing water. any suggestions.

geebeemer
11-19-2009, 07:46 AM
edit: Ohhh, scratch that... I had it backward....

Tourburgring
11-19-2009, 11:19 AM
on the motorway at 70ish the heater blows cold when you stop or drive slow it warms up.pollen filters were blocked now removed,thermostate has been replaced. engine temp stays dead half way on the gauge when warmed up and does not budge. it does not appear to be losing water. any suggestions.

It certainly sounds like your thermostat is stuck open, but if it has been replaced that is unlikely. The Heater control valve often sticks with age restricting the hot coolant flow to the heater core. There are actually two valves one for driver and one for passenger, but they are both located together in the same unit on the passenger side of the engine compartment near the firewall. From the top they look like two silver metal discs. You may get lucky and free them up by setting the heater controls to full hot with the engine running and then tapping the silver tops with the handle of a screwdriver or something. Not so hard that you may damage them but hard enough to shock them into moving. If this doesn't work them disassembly of the valve and cleaning is the next stage (refer to Bentley manual procedure). Another possibility is a blocked heater core.