PDA

View Full Version : Tran Program


limbo
12-15-2009, 07:11 PM
I have a 1992 bmw 525i, pull down the auto tranny to replace the rear engine seal, front and rear tranny seals. Drove for the night and on my way to work the next morning tran program check owner manual came up. car move very slow or not at all unless i switch it off. :dunno: oh i look for loose connection on the tranny and i change the shifter.
can you give me an idea of what to do next. :dunno:

Rodrick Msuya
12-15-2009, 11:27 PM
what type of ATF did you use, and was the used ATF duty. If so then I would recommend draining the ATF several times to get all the old ATF out.

Things to check:
-recommended ATF should be used
-recommended ATF qty and proper refilling procedure should be followed
-check for leaks after two days or so

JDawg965
12-16-2009, 06:17 AM
I just had the "trans program" on my 93 525i... all i did was give the battery a good full charge, and then reconnected it and it was gone!!! it shifts slow because when the "Trans Program" comes on it sets the trans in 3rd gear so it wont burn it out in case there is something wrong with it... i would check the battery make sure it is fully charged and semi new, if not re charge or replace... Low voltage can cause weird things on these cars as i found out recently... I am use to having American cars and never had any of these problems but after doing some searching you find out a lot about these cars where you can get all sorts of messages due to the tiniest little things... let me know what you find out!

limbo
12-19-2009, 08:47 PM
Thanks guys for your reply:)

Its was refilled to the right level and i check for leaks but no leaks. I used dextron type 2 ATF. I ordered a rebuild master kit online to rebuild the original tranny i have in the shop. You think i should also get a new torque convertor? The only problem the original tranny had was it took a few seconds before it engage the reverse. Any advice on the rebuilding of the tranny. :dunno:
Oh also i have a new battery on the car. Charging system is ok

2winbmw
12-23-2009, 04:45 PM
i just had to change my alternator...on my way to drop the car off the trans program came on....in my case the faulty alternator caused it

Rodrick Msuya
12-28-2009, 10:13 PM
Funny thing that I found out and also stupid as far as I am concerned about this transmission safemode function is that the transmission ECU can switch to this safemode regardless to what speed you are doing at the time.

It once happened to me, when I was doing 120km, there was a boom then the tranny went to 3rd gear then as you all know, the engine reved so high and quickly I had to push the shifter to 'N' so as to disengage the transmission from the diff.

This surely can damage the engine and the tranny. If only there was a way of disabling this function or disconnecting any wire that triggers this function or send the 3rd gear request to the transmission box.

limbo
12-29-2009, 07:21 PM
Today i remove the tranny bottom pan and i notice it has some clutch deposit and the fluid smelled kinda burnt.
I am rebuilding the original tranny so i will put in on soon.