PDA

View Full Version : DSP Settings


SodaJerk
10-07-2003, 07:41 PM
Hi All,

I have had my 2003 X5 4.4 for about 2 months now. After trial and error and use of my (ahem!) sophisticated test equipment http://www.bimmerfest.com/forums/images/icons/icon10.gif (my ears!) I have found that the attached DSP and Head Unit settings work well for me.

With these settings, the bass response is acceptable for me and the imaging with the fronts works ok too. I have not decided whether the bass sounds better with the rear cover on or off.

I was originally considering all sorts of options to improve sound quality (replacement speakers, replacement/add-on subs, etc). But after using these settings, I think I am going to live with the stock system for a while and maybe next year I will reconsider some of other options. This is partly because I don't want to start modifying my 8 week old baby and partly because I don't want to spend to $1000~$1500 right now.

Let me know if these help anyone in a similar situation.

Clarke
10-08-2003, 03:13 AM
Well tastes certainly vary. When we picked up ours I was quite worried about the quality of the system it was very muddy and boomy.When I checked the settings I found someone had set it up similarly to yours.I now run almost the opposite settings and am pretty happy.Tight & sharp but still kicks the rearview mirror when cranked.I may have to do something to give it a little more headroom at high volumes though.It is nice that its tunable to everyones varied tastes.

SupraRZ
10-11-2003, 05:58 AM
Speaking of CD changers, is it possible for track names to show up on the NAV screen?