PDA

View Full Version : Service Light


Simple Pleasure
05-05-2010, 03:07 PM
Hi, never posted before as I have had no issues with the Dealer or my X3, but my 2010 528i has a red service light with a car symbol in the center of the dash cluster upon start up and the yellow triangle, Service Writer and Mechanic said it was normal, now in addition to this "Service Overdue" is appearing on the "I" drive screen. I contacted the Dealer two days ago and I am still waiting for an answer, I would appreciate it if anyone could lead me in the right direction.

bmrboy2008
05-05-2010, 05:29 PM
I would think any red or yellow check engine light is not normal. Moreover, the dealer taking two days to get back to you is definitely not normal. If you do not get a telephone call from the dealer tomorrow, I would call the service manager, let him know what you are experiencing and request an appointment to discuss the issue and have him inspect your car personally.

Not sure how many miles you have on your 528i, but a 2010 is practically brand new and you should be getting the royal treatment from your dealer on an issue like this so soon. Sometimes SA's forget that it is we who are paying their salaries.

Good luck and keep us posted.

JerseyGeorge
05-05-2010, 07:31 PM
Just make an appointment for service. The Idrive is telling you service is overdue so get it serviced! Any BMW dealer can service your car.

Simple Pleasure
05-06-2010, 10:02 AM
Still no call back today, went to the Dealer and they immediatly reset the lights they told me it is scheduled to go on with every new car at 8,000 miles. Thanks for your replies.

SandNs new 528
05-06-2010, 10:14 AM
Still no call back today, went to the Dealer and they immediatly reset the lights they told me it is scheduled to go on with every new car at 8,000 miles. Thanks for your replies.

How many miles on your car?

JerseyGeorge
05-06-2010, 01:05 PM
How many miles on your car?

My guess 8000 miles:confused:

bimmerguyjoey
05-06-2010, 01:17 PM
8,000 miles and all of these problems? Man maybe I should reconsider getting a high milage E60?

mleerob
05-06-2010, 02:06 PM
8,000 miles and all of these problems? Man maybe I should reconsider getting a high milage E60?

I'll trade my 08.

Simple Pleasure
05-06-2010, 03:44 PM
Exactly 8,000 miles today but the first light, the car symbol in the center of the dash cluster which is usually yellow upon start up was red and the word Service was underneath the symbol has been on since about 6,500 miles. I also found out today that the Service Writer that told me it was normal, was his first day, but that dosen't excuse the Mechanic that told me the same thing.

bmrboy2008
05-06-2010, 05:13 PM
I'll trade my 08.

Me too!!!

bmrboy2008
05-06-2010, 05:14 PM
Still no call back today, went to the Dealer and they immediatly reset the lights they told me it is scheduled to go on with every new car at 8,000 miles. Thanks for your replies.

That's weird. What the hell for if they are just going to reset it. :dunno: