PDA

View Full Version : help


chross12
05-09-2010, 04:54 PM
My 550 is having a battery issue? I checked the battery at my local autozone and it was ok, as was the alt. However the starter was pullling 280 amps/? Is this normal? Or is my problem a bab starter?
thanks in advance for all help

-Howitzer-
05-09-2010, 06:09 PM
What year is your car? If anything older than 4, replace the battery. If not, you may want to get a trickle charger because these newer Bimmers are known to have issues with the electrical system draining more power than what the battery can offer. Plainly put; the newer BMW needs a bigger battery, period. The car pulling high amps on startup is normal.

chross12
05-09-2010, 06:17 PM
It is a 2006 550i. The battery eye is black, however battery is pulling 12.7 amps. Starter is pulling 280 amps while running. Is this normal amps for starter? Thanks for any help given.

-Howitzer-
05-09-2010, 06:27 PM
A good starter will normally draw 60 to 150 amps with no load on it, and up to 200 amps or more while cranking the engine. The no load amp draw depends on the rating of the starter while the cranking amp draw depends on the displacement and compression of the engine. Always refer to the OEM specs for the exact amp values. Some "high torque" GM starters, for example, may have a no load draw of up to 250 amps. Toyota starters on four-cylinder engines typically draw 130 to 150 amps, and up to 175 amps on six-cylinder engines. SO, considering you have a big V8, your starter sounds perfectly normal.

Regardless, your battery is getting there and I would say that in a year or less you'll need a new one. I got an Interstate battery that had a 7 yr warranty and better cranking amps than OEM for only $80. The dealer will charge you $300+. Keep that in mind.

sph17
05-09-2010, 07:10 PM
I had battery issues with my E39 that turned out to be a bad contact between the battery and the clamp, no matter how much I cleaned the post and the clamp and no matter how tight I made the clamp.

I solved the problem by using two small screws, and screwing them between the clamp and the post to ensure good contacts.

dpm550i
05-09-2010, 07:30 PM
My 550 is having a battery issue? I checked the battery at my local autozone and it was ok, as was the alt. However the starter was pullling 280 amps/? Is this normal? Or is my problem a bab starter?
thanks in advance for all help

SA told me that the 550i will say in standby mode and draw on the battery if you do not lock the doors. He said if you are a driver who only makes short trips the battery never has a chance to fully charge and will eventually drain down. He said if the battery is less than 65% the clock will not hold the time. That is a warning.

E92-Lighting
05-10-2010, 10:45 AM
the battery definitely needs to be replaced, but the 7's seems to have a lot more battery issues when compared to the 5

skylolow
05-10-2010, 10:45 AM
My 550 is having a battery issue? I checked the battery at my local autozone and it was ok, as was the alt. However the starter was pullling 280 amps/? Is this normal? Or is my problem a bab starter?
thanks in advance for all help

Many people have had batteries pass test but because of the electronics of these cars they pull considerable more off the battery. If the systems doesn't see the power it wants it shuts down things while driving or do nothing when you try to start it. Even though the power may be more then enough for 90% of the cars on the road.

I would try replacing the battery with the exact spec battery and see if it solves your problem. Either way being that its a solid 4 years old it isn't going to hurt anything. Then make a choice if you want to get the battery registered at the dealer (about $100 to do).