PDA

View Full Version : Countdown To Service Stalled


x3ronnie
05-16-2010, 06:32 PM
When I start the car, the mileage to the next service seems to have stopped at 14,000 miles. It has not moved after driving several hundred miles (at least) if not more. I purchased this as a CPO with no service due for a bit, so I am not overly concerned right now. Still this seems a bit strange.:dunno:

JerseyGeorge
05-17-2010, 12:08 AM
Condition Based Service.......your BMW with it's various sensors and algorithms determines when your car needs servicing. All this varies on your driving....highway/stop and go, temperature, etc!

I also have changed my oil and reset the service indicator only to have the service indicator seemingly stick at 14K. I personally change the oil at 10K based on the actual odometer reading and reset it myself!

x3ronnie
05-17-2010, 02:01 AM
Condition Based Service.......your BMW with it's various sensors and algorithms determines when your car needs servicing. All this varies on your driving....highway/stop and go, temperature, etc!

I also have changed my oil and reset the service indicator only to have the service indicator seemingly stick at 14K. I personally change the oil at 10K based on the actual odometer reading and reset it myself!

I did NOT change the oil myself, and am therefore wondering why the service indicator is frozen. My concern is not just for oil changes. The BMW maintenance schedule calls for various services to be performed at regular intervals. Without the indicator acting as a guide, I feel somehow 'lost'. My previous BMW's were leased, and therfore not kept for the long term.

waiting
05-17-2010, 05:44 AM
It only changes in increments of 1000 miles until you get around 1000 miles left.

jesimmons
05-17-2010, 06:00 AM
it only changes in increments of 1000 miles until you get around 1000 miles left.

+1 !

sunburst1
05-17-2010, 06:18 AM
Hey x3ronnie are you going to the new owners appreciation/owners clinic on Tuesday(05/18) at 6:00PM?

I live in Auburn and just bought an '07(sapphire metallic ,cold weather,premium, steptronic) CPO 525xi about two weeks ago. I'll be asking a lot of dumb questions only newbies ask. :rofl:

Since the manager already gave me an oil service coupon, I'll probably snag the all-weather floor mats. ;)

Hope to see/meet you there, Dave. :)

x3ronnie
05-31-2010, 12:05 PM
Hey x3ronnie are you going to the new owners appreciation/owners clinic on Tuesday(05/18) at 6:00PM?

I live in Auburn and just bought an '07(sapphire metallic ,cold weather,premium, steptronic) CPO 525xi about two weeks ago. I'll be asking a lot of dumb questions only newbies ask. :rofl:

Since the manager already gave me an oil service coupon, I'll probably snag the all-weather floor mats. ;)

Hope to see/meet you there, Dave. :)

I just saw your message Dave. Sorry. I have been busy with work and have yet to get a new owners event for this car. Been to three so far.

As to my original post---Still says 14K miles. This thing is stuck! Any thoughts?

JerseyGeorge
05-31-2010, 10:32 PM
I did NOT change the oil myself, and am therefore wondering why the service indicator is frozen. My concern is not just for oil changes. The BMW maintenance schedule calls for various services to be performed at regular intervals. Without the indicator acting as a guide, I feel somehow 'lost'. My previous BMW's were leased, and therfore not kept for the long term.

It isn't frozen!! It is "CONDITION BASED" NOT a fixed mileage! If you don't believe me do some research yourself.....check with the dealer, Internet, search this forum!

If you don't want to go by BMW's condition based service intervals then your going to have to shell out the money pay for it. That's why I said I change my oil every 10K and reset myself. The reset is because I don't want to see the service indicator light. Some people here change the oil at 7500 during warranty and don't reset so that the dealer changes the oil at 15K.......oil gets changed twice but you pay for one.

x3ronnie
06-01-2010, 03:19 AM
I guess I am expecting it to move as I drive. My previous X3's did this all the time. Why is the 5 series so different?

x3ronnie
06-06-2010, 10:51 AM
Well it FINALLY moved. It now stands at 13,000 miles. :thumbup:

sunburst1
06-06-2010, 05:09 PM
Well it FINALLY moved. It now stands at 13,000 miles. :thumbup:



Hey x3ronnie just saw your reply. Noticed mine just did the same thing. It was at 9K now stands at 8K after driving just over 1000 miles. Must move every thousand like others said.

Still hope to meet up with you at the next owners clinic, since I missed the last one. :cry: