PDA

View Full Version : Blown out PSS9's?


baller99
11-16-2003, 04:26 PM
I am riding on Pss9's on my 330i and have recently heard strange noises coming from the shocks. I checked out the shocks and to my suprise, one of my rear tires seems to be riding on nothing but springs. I have heard that PSS9's have a tendency to go bad because of a prematurely worren out washer. I want to know if anyone else has had this problem, and where I can get replacement washers for it.

SergioK
11-17-2003, 08:54 AM
I checked out the shocks and to my suprise, one of my rear tires seems to be riding on nothing but springs.

The only thing that keeps the car 'suspended' per se is the springs. Shocks DO NOT carry the weight of the vehicle. Over time, the shock will fully compress if not for the spring which is carrying the weight of the vehicle. Every shock in every car on the road is like this, even on a PSS9 kit.

Also, how do you know for sure the noise is coming from the shock? How have you tested them?

baller99
11-17-2003, 02:39 PM
The only thing that keeps the car 'suspended' per se is the springs. Shocks DO NOT carry the weight of the vehicle. Over time, the shock will fully compress if not for the spring which is carrying the weight of the vehicle. Every shock in every car on the road is like this, even on a PSS9 kit.

Also, how do you know for sure the noise is coming from the shock? How have you tested them?

The shock is physically hanging down toward the ground.

TGray5
11-17-2003, 02:53 PM
The shock is physically hanging down toward the ground.

Sounds like it was installed without the proper washer...I have heard of this before. I'd take it back to your installer and be very careful with driving it. I don't think there is anything wrong with the shock itself.

SergioK
11-17-2003, 03:00 PM
Sounds like it was installed without the proper washer...I have heard of this before. I'd take it back to your installer and be very careful with driving it. I don't think there is anything wrong with the shock itself.

More like it wasn't properly torqued! I think spec on that bolt is 110nm.