PDA

View Full Version : No power to seats or idrive control


montehall
07-08-2010, 03:22 PM
I pulled my center console out yesterday to vacuum the AC ducts. I put it back together and now I have no seat controls and the idrive wheel wont function. The only connectors I pulled were the rear fans and the power outlets... which still work and so does the led light at the front of the console.... any ideas?

amg142
07-08-2010, 04:00 PM
theres a wire that connect right under the idrive control knob of the center console. When disconnected u get no power to seat control or idrive knob

montehall
07-08-2010, 04:01 PM
theres a wire that connect right under the idrive control knob of the center console. When disconnected u get no power to seat control or idrive knob
Is it a small 4-pin black connector? I can't find where the jack is for it

amg142
07-08-2010, 04:55 PM
Is it a small 4-pin black connector? I can't find where the jack is for it

same thing happened to me lol. the jack is located right under the idrive unit on center console. its a pain to clip on bc the wire is really short. basically the center console has to be almost closed for it to reach.

TechFreak
07-08-2010, 04:55 PM
Is it a small 4-pin black connector? I can't find where the jack is for it

IDrive connector :

http://www.xolmatic.com/xprojects/XE65/Consola_Central/IMG_0807.JPG

You can just see the IDrive connector in the centre offset left in the photo below :

http://www.xolmatic.com/xprojects/XE65/Consola_Central/IMG_0804.JPG

montehall
07-08-2010, 07:08 PM
Hey thanks for the help... that plug is pretty hidden, but that fixed it. Thanks again.