PDA

View Full Version : HVAC blower fan speed


djeargazm
07-12-2010, 11:20 AM
My 7's fan speed seems to have a mind of its own. Sometimes the MAX A/C button actually does what you'd think it does... turn the fan up to a super high speed. Sometimes it has no effect.

Sometimes when I first get in the car after baking in the sun, the A/C will automatically turn on at full speed. Other times, the A/C will turn on at a more moderate or regular pace, as if the cabin was already at the set temp. Then, several minutes later, it might ramp up to full speed until the cabin cools off.

It appears to be completely random. I can't pinpoint any set of circumstances that has any commonality with when the fan acts up.

Is there a Gremlin behind my dash just screwing with me on the hottest of days or is this a known issue? Any suggestions? :dunno:

sims1dh
07-12-2010, 12:32 PM
Mine did that when my battery was going bad.

djeargazm
07-12-2010, 02:25 PM
Mine did that when my battery was going bad.

Interesting... I wouldn't assume that a weak battery could have any effect on the fan speed control... especially while the car is running.

I guess you don't need to own this car for more than a week before you learn to NEVER assume anything though!

Anyone else ever experience this?
Thanks,
Joe

greco2000
07-12-2010, 03:43 PM
Happens to me too. SOmetimes I crank it on max AC and I dont feel much, then out of nowhere, a rush of air. I always thought it had something to do with a sensor. I wouldnt mind knowing the reason either!

sims1dh
07-12-2010, 03:54 PM
Guys I'm not one hundred percent sure that the new batt will solve your problem. I found out that my battery might be bad after reading a few post on the forum. I had several issues that I read was related to low battery voltage. My fan was not blowing hard all the time and I started getting seatbelt and airbag lights coming on. I went to autozone and had them check the battery and sure enough it was weak. Everything else worked fine. I also noticed that if i sat in my car with the engine off and the radio on, after 2 min I would get a recharge your battery light.

cjennjr
07-13-2010, 09:36 AM
I had the same issue with the radio after 2 minutes - the dealership replaced the battery and I've not had that issue since. I also purchased a trickle charger since I only drive my car once or twice a week to keep battery fully charged.

Keif
07-13-2010, 03:09 PM
People have also had issues with the final stage resistor...there should be some threads about this if you do a search using that.