PDA

View Full Version : Navigation Problem


mzwicker
10-24-2010, 06:47 AM
Just picked up my car (535ix) and the navigation showed that we were in the middle of the Ocean. CA told me to ride around and it would probably reset.

No such luck. Guess I'll making my first service call Monday.

Besides this the car is wonderful.

pharding
10-24-2010, 07:00 AM
It must think that you have the new boat option.

bfv
10-24-2010, 07:01 AM
Keep a life jacket in the car :rofl: Not enough space to keep it in the car though !:mad:

mzwicker
10-24-2010, 07:46 AM
So that's what the prop is for under the bumper. And they didn't even charge me for that option.

annaduchene
01-24-2011, 05:52 PM
um good luck still fighting with customer relations about the horrible system. says my responsiblity to call vendor? really??? should i call the vendor when the tires blow too? my nav cant even recognize major highways! ford has a better system!

jhbarc
01-24-2011, 06:02 PM
um good luck still fighting with customer relations about the horrible system. says my responsiblity to call vendor? really??? should i call the vendor when the tires blow too? my nav cant even recognize major highways! ford has a better system!

I have not had any issues with my Nav.

1HOT BMR
01-24-2011, 08:12 PM
Now I take my Garmin ($150) with me every time I take the BMW - yes, the BMW navigation system sucks! :irate: My Acura RL system was precise, super easy to use, never gave me wrong information, and never got me lost. The system in the 550 is as bad as the one in my wife's VW - same manufacturer? :thumbdwn:

mzwicker
01-24-2011, 08:38 PM
Had the same problem, after two days in service they found out that the antenna was not connected.

mark2895
01-24-2011, 09:16 PM
A friend with a new X5 had the same problem, antenna was disconnected. Might be the same issue with yours.

anthony@empireleasing
01-25-2011, 10:56 AM
I only notice this issue when i enter a tunnel and come back out the car is lost..dead reckoning not working correctly

eyesight1
01-25-2011, 11:03 AM
Knock Wood I have not had any issues. My nav seem to work well.

purebimmer
01-25-2011, 03:45 PM
I have the same problem in my 550i GT and taking it to the dealer tomorrow.

annaduchene
01-25-2011, 03:59 PM
let me know what the dealer says, i am on day 3 of no callback from dealership and from the manager MARISSA at Customer RELATIONS BMW. they are totally avoiding this issue.

purebimmer
01-28-2011, 12:29 AM
I have the same problem in my 550i GT and taking it to the dealer tomorrow.

Dealer said yesterday that it's a bad nav module and will take at least 2 days to repair. Dealer didn't have a loaner vehicle until 2/9/2011 so we will bring back the vehicle then. In the mean time, people are wondering why I am using a Garmin Nuvi in a 550i GT with NAV :confused:

purebimmer
02-16-2011, 01:39 PM
Just to update of the repair on the Navigation system of our car. We brought our car back to the dealer on Wed, 2/9/2011, and after a week of removing most the components in the dash and consulting with BMW N.A., they determined this morning that it was a defective Nav antenna. I've mentioned this to the service advisor last week that I've read of the antenna issue in the BMW forums. Instead, they took another car with the same NAV system and started to swap components to determine the fault. I asked her how many components were swapped, and she indicated four or five and all were in the dash. I can just picture our car has the entire dash removed and maybe including the front seats. Moreover, the service advisor indicated that the Nav antenna is a "national back order" until next month so we need to bring our car back in on Saturday March 5, 2011. We now fear the tightness of a new BMW may be compromised as interior parts were removed and reinstalled.

mzwicker
02-16-2011, 03:12 PM
Just to update of the repair on the Navigation system of our car. We brought our car back to the dealer on Wed, 2/9/2011, and after a week of removing most the components in the dash and consulting with BMW N.A., they determined this morning that it was a defective Nav antenna. I've mentioned this to the service advisor last week that I've read of the antenna issue in the BMW forums. Instead, they took another car with the same NAV system and started to swap components to determine the fault. I asked her how many components were swapped, and she indicated four or five and all were in the dash. I can just picture our car has the entire dash removed and maybe including the front seats. Moreover, the service advisor indicated that the Nav antenna is a "national back order" until next month so we need to bring our car back in on Saturday March 5, 2011. We now fear the tightness of a new BMW may be compromised as interior parts were removed and reinstalled.

I was lucky that they only replace the nav module before checking the antenna, the antenna was defective.

iroquis_pliskin
10-27-2011, 07:25 PM
I got the same problem on my M6, I did buy a new antenna and it only worked for 2 days.
now the sat nav is not showing my current position.
any updates from you guys?

Arnie335
12-05-2011, 07:25 PM
+1

First time I called BMW, they too said I needed to contact the manufacturer of the unit or see my dealer.

Took it in for service - they failed to replicate the issue, of course. Map showed me in pacific ocean again (does this mean BMWAssist can't locate me in an emergency?)

Called again. This time the Customer Rep said the issue is a known issue with no resolution expected until early 2012. He said to use my iPhone.

My GPS works intermittently - probably about 30% of the time. Not cool. :thumbdwn:

apw2607
12-05-2011, 08:24 PM
On the BMW assist question ... Technically yes. The nav system sends location to the combox for BMW assist. Best thing to do is call BMW assist. They will tell you where they think you are. Although I doubt they will admit you are in the middle of a ocean.

When you say failed to replicate issue, does this only happen some of the time? If that's the case, next time it happens take a screen shot with phone or video and then show it to dealer. Best way to document intermittent problems.

Could be a faulty CIC unit (most likely), faulty gps antenna (shark fin) or pinched coaxial antenna cable.

alewifebp
12-05-2011, 09:42 PM
I had the same problem years ago with my E Class. They ended up updating the software with a new map disc, and it fixed the problem. You might get lucky and get the new map disc out of the deal, a $500 value!

Needsdecaf
12-06-2011, 05:27 AM
There are no map discs.

Sent from my DROIDX using Bimmer

PsychDoc1
12-06-2011, 05:31 AM
Keep a life jacket in the car :rofl: Not enough space to keep it in the car though !:mad:

Car comes equipped with run flat floatation devices...complete with the obligatory bubbles (which really look cool out there in the middle of the ocean).
:bigpimp:

PsychDoc1
12-06-2011, 05:32 AM
I have not had any issues with my Nav.

I suspect you've never used your nav then!
:D

GunsBMW
12-06-2011, 07:00 AM
My Nav issue is it wont go in night mode anymore. I played with the settings and everything. Now if I have it in split screen, it goes in night mode but the main screen stays in day mode. I can live with it for now intil I can take it in for repairs.

mrcamp
12-06-2011, 08:17 AM
I have mine set to auto, however the thing seems to just always stay in day mode. I have not really played with it to see if split screen matters or not.

My Nav issue is it wont go in night mode anymore. I played with the sittings and everything. Now if I have it in split screen. That part goes in night mode but the main screen stays in day mode. I can live with it for now intil I can take it in for repairs.