PDA

View Full Version : 528 X-Drive Poor Heater Performance


CLannom
02-10-2011, 09:14 AM
Bitter cold in Minnesota these days and when the temps fall below 0, my heater only puts out warmish air. Thank goodness for heated seats and steering wheel. Been to dealer and they say it's working correctly. Anybody else experience this?

bmw_n00b13
02-10-2011, 09:44 AM
How far are you driving?


Sent from my iPhone. Please excuse typos and lack of links.

CLannom
02-10-2011, 01:20 PM
After a 20' drive it is only putting out mildly warm air!

mason
02-10-2011, 03:52 PM
After a 20' drive it is only putting out mildly warm air!

20 feet? Of course, no warm air. Warm air mainly comes from heat of the engine. May be that's why people install remote start. You see plenty of Canadians dangle an electrical outlet in front of the grille. They plug the car in at home or in door garage to keep the engine block warm.

CLannom
02-10-2011, 04:31 PM
Not 20 feet, 20 MINUTES! By then it is only moderately warm.

mason
02-10-2011, 07:02 PM
20 minute would be unusual. I would try different dealer.

nosnoop
02-16-2011, 12:27 AM
Not 20 feet, 20 MINUTES! By then it is only moderately warm.

Did you turn the knob in the center vent to "Red"?
And try using manual distribution control instead of "Auto". Switch the air to come out from middle vent only, and you should get much warmer air.

csmooth79
02-23-2011, 01:46 PM
Did you turn the knob in the center vent to "Red"?
And try using manual distribution control instead of "Auto". Switch the air to come out from middle vent only, and you should get much warmer air.

+1 check out the menu settings as well