PDA

View Full Version : Couple Questions (Radio-Beeps)


Domer
02-09-2004, 06:05 PM
I have a couple questions for the experts...

1. My radio seems to be having a hard time picking up stations in the city. Anyone else have similar experiences? I live in the middle of the city and have NEVER had problems getting the stations I'm talking about with any car. Is there possibly a problem, or can I somehow boost the reception?

2. In my car, there is a series of 3 beeps that go off after driving for a little bit. I'm not sure what they mean, but it seems to happen and then the AC or Heat kick in... Here are my thoughts. Could this be something alerting me that the car is now warmed up and it will begin maintaining the temperature? Or is this something completely different. There are no indicators on the dash when the beeps happen.

Here are my options/configuration:

2004 X5 4.4i
Premium, Cold Weather, Sport Package
GPS, DSP, PDC, Hill Decent

Thanks!
Tom

capt-phil
05-19-2006, 06:45 AM
Hi,

I have a 2002 X5 and it does the same thing, did you ever find out what it is?:dunno:

piper51
05-20-2006, 01:51 PM
My 2001 has great reception on FM, but not a thing on AM. Is there something I can reset or what. I do like to listen to a couple of the AMs in my other ride, but :dunno:

Any help from someone really would be appreciated.
Thanks

Zulu95
05-20-2006, 01:54 PM
I remember reading something about a TIS on poor radio recption and an updated antenna amp replacement being offered on a "Per customer complaint" bases only. Might be worth calling the service dept. at your dealer.