PDA

View Full Version : DIY - How To Update Transmission Software (2-1 Shift problem)


mortyx10
05-19-2012, 07:59 PM
Hello everyone.

This issue is a very well known issue and we all know there are few solutions out there such as Guibo, tranny oil, software update, etc.
There are DIYs for most of the solutions but I couldn't find a DIY for software update. most saying you have to take it to the dealer. Since I like to DIY everything possible I managed to update my transmission software and it really makes a difference.

I'm assuming you have your cable and know how to install drivers and stuff

1. Download and install BMW standard tools. It contains INPA, NCS, winKFP, and tool32.
This will only install the programs, you need the sp-daten files for e65.
http://www.mediafire.com/?xg3ms9lk59vslxc

2. Use the attached guide to setup winKFP.

3. Open INPA>>choose chassis>>Transmission>>Gearbox Control module>>Identification (F2). now press arrow down on your keyboard and take note of your Assembly number. Close INPA

4. Open winKFP>>Comfort mode>>Enter ZUSB and Enter the assembly number.>> Take note of your ECU family.

5. Now press F3 (Update ZUSB) and choose your ECU family.>>Ok

6. F4 (Enter VIN) and enter your full VIN number. >> Ok >>F8 (DONE).

7. F3 (Prog. ZB-Update). Here a pop up shows you your current and updated assembly number. If they are the same you already have the updated software but if not press okay.
Another pop up asking permission to program ecu....press okay and your done.

It took about 5 mins. so if your car's battery can hold up for 5 minutes you'll be alright.

At the end it should tell you that the programming was okay.

I reset my adaptation values using INPA after it was done and believe me it makes a huge difference. 2 to 1 jerk is 99% gone. I think I also need to change tranny oil and it'll be 100%.

Hope this helps.
Thanks

x3lemon
05-19-2012, 09:04 PM
I've been looking for how to do this. Will try. Thanks for posting.

mortyx10
05-19-2012, 09:18 PM
I've got mine from here www.bmwcoding.com/showthread.php?1938-Usenet-files&highlight=usenet

You can use a free trial and unsubscribe before you have to pay.

x3lemon
05-20-2012, 09:24 AM
I've got mine from here www.bmwcoding.com/showthread.php?1938-Usenet-files&highlight=usenet

You can use a free trial and unsubscribe before you have to pay.

I downloaded what I thought were the right daten files but the folder structure didn't match what you have listed in the winkfp PDF. Can you tell me exactly which files an from where to download for a 745li 2005. Feel like I'm almost there!

mortyx10
05-20-2012, 05:12 PM
I downloaded what I thought were the right daten files but the folder structure didn't match what you have listed in the winkfp PDF. Can you tell me exactly which files an from where to download for a 745li 2005. Feel like I'm almost there!

I think you downloaded v46 which is a lite version, get v45, you don't need other chassis just e65.
You can also use your existing files if you have inpa and ncs installed, because this update is so old you don't need the newest files

x3lemon
05-20-2012, 07:53 PM
I downloaded ver 4.5. In step 6 on winkfp I don't see the data folder anywhere.

mortyx10
05-20-2012, 09:39 PM
I downloaded ver 4.5. In step 6 on winkfp I don't see the data folder anywhere.

It must be there...it is in the main folder. SP-Daten-E65/data. I don't know if it isn't. Its more than 1gb, otherwise I could upload it for you.

Dead
05-21-2012, 09:38 AM
thanks mortyx10

SP-daten v 41 for e65 https://rapidshare.com/files/2644713914/E65_V41_Daten_Files.rar

file size 385mb

after decompress 1.29gb

latest update for e65 is v 41 so v 45 is the same as v 41

07jace750li
05-21-2012, 11:32 AM
Hey guys I'm looking to update my software and really don't wanna go to the dealer...question forgive my ignorance but I just got my first BMW and don't kno anything bout it till I sign up to this awesome forum I have a 2007 750 li if I update the software what different would it do to my car and do I also need a diagnostic tools if I decide to DIY it??

mortyx10
05-21-2012, 06:14 PM
thanks mortyx10

SP-daten v 41 for e65 https://rapidshare.com/files/2644713914/E65_V41_Daten_Files.rar

file size 385mb

after decompress 1.29gb

latest update for e65 is v 41 so v 45 is the same as v 41

Thank you...very useful.

mortyx10
05-21-2012, 06:18 PM
Hey guys I'm looking to update my software and really don't wanna go to the dealer...question forgive my ignorance but I just got my first BMW and don't kno anything bout it till I sign up to this awesome forum I have a 2007 750 li if I update the software what different would it do to my car and do I also need a diagnostic tools if I decide to DIY it??

The procedure is the same as above for every module but remember it could take hours. you better have a power supply connected to your car. but for transmission that is being discussed in this thread, it only takes minutes. tools you need are the ones posted here.

x3lemon
05-22-2012, 03:52 PM
So I managed to install the software as per the instructions! When I launch INPA nothing displays except Battery Off Ignition Off. The cable is a usb cable that is connected to the OBD port on the car. Tried it with car on and off, ignition on and off. Windows did automatically install the drivers for the cable so I don't know what the issue is. Is there a way to troubleshoot the connection?

mortyx10
05-23-2012, 12:22 AM
So I managed to install the software as per the instructions! When I launch INPA nothing displays except Battery Off Ignition Off. The cable is a usb cable that is connected to the OBD port on the car. Tried it with car on and off, ignition on and off. Windows did automatically install the drivers for the cable so I don't know what the issue is. Is there a way to troubleshoot the connection?

Download the following and copy the files you missing in your INPA folder.
BIN, CFGDAT, SGDAT are the important ones.
http://www.mediafire.com/?58qfq1d9qq8d8rm

hd750Li
05-23-2012, 05:12 AM
Man! This post is so valuable and informative. It should be in the sticky or moved to DIY session.

Just a suggestion Morty, PM the forum moderator to have it moved.

I would also suggest the same for the other VIM DIY post.

Thanks buddy! E65 community is lucky to have someone like you here Morty!

wthreez
05-23-2012, 01:51 PM
What is this 2-1 shift problem. Like what are the symptoms that way I know I know what to look out for

x3lemon
05-23-2012, 04:22 PM
Download the following and copy the files you missing in your INPA folder.
BIN, CFGDAT, SGDAT are the important ones.
http://www.mediafire.com/?58qfq1d9qq8d8rm

Thanks. So now I see all the options on inpa. But I can't get the Assembly number - I get an error. The red light on my cable never goes off and the black dots in the software are clear.

Its clear the cable is not communicating with my laptop. Can you walk me through installing the drivers?

mortyx10
05-24-2012, 12:02 AM
Man! This post is so valuable and informative. It should be in the sticky or moved to DIY session.

Just a suggestion Morty, PM the forum moderator to have it moved.

I would also suggest the same for the other VIM DIY post.

Thanks buddy! E65 community is lucky to have someone like you here Morty!

Hey man, Thanks for the complement. I'm nothing like what you saying. I have learned a lot in this forum and trying to give something back. I will try to contact the mods see what they say.
Thanks again.

mortyx10
05-24-2012, 12:06 AM
Thanks. So now I see all the options on inpa. But I can't get the Assembly number - I get an error. The red light on my cable never goes off and the black dots in the software are clear.

Its clear the cable is not communicating with my laptop. Can you walk me through installing the drivers?

If the circules are not black, you are not communicating with your car.
Have a read at these and see if you get it working or not.

mortyx10
05-24-2012, 12:23 AM
What is this 2-1 shift problem. Like what are the symptoms that way I know I know what to look out for

It's a little kick you get when you are about to fully stop. The older software tells the gearbox to change to 1st just before the car comes to a stop so you feel a kick. Some say with the new updated software it does not change to 1st at all and starts from 2nd. but in my case it waits for the car to fully stop and then changes to 1st. As I said this is only 100% effective when it is done along with tranny fluid, guibo, etc. However you feel the difference right away.

Mr_Burger
05-24-2012, 06:05 AM
Does this help too? http://www.bmwcoding.com/showthread.php?2884-E6x-harsh-2-1-downshift....

x3lemon
05-24-2012, 04:07 PM
Sold my 2005 745 today so don,t need to figure out how to make this work. Thanks for all your help guys. Might need it again when I buy my 760!

07jace750li
05-25-2012, 07:16 AM
The procedure is the same as above for every module but remember it could take hours. you better have a power supply connected to your car. but for transmission that is being discussed in this thread, it only takes minutes. tools you need are the ones posted here.

Thanx

ausbmw87
05-26-2012, 10:27 PM
to complete this update can the car be running ? ? i am just worried about the battery getting drained ? ?

ausbmw87
05-30-2012, 10:47 AM
anyone ? ? help in reguards to the car been on and running while the update is completed ? ?

flash_n
05-30-2012, 08:53 PM
Thank you for the write up.
When trying to perform step 7 i got the error "security access denied" and the flash would not proceed.
I had to change the configuration of WinKFP for fast baud rate to successfully flash. Seems like there are differences from ECU to ECU.
My update to the dynamic drive ECU required the fast baud rate to be disabled.

mortyx10
06-02-2012, 07:08 PM
anyone ? ? help in reguards to the car been on and running while the update is completed ? ?

Well I don't know man...I have done simple codings while the engine running without any problem but don't know about software update. As I said it didn't take very long for me. but you know your battery better.

mortyx10
06-02-2012, 07:10 PM
Thank you for the write up.
When trying to perform step 7 i got the error "security access denied" and the flash would not proceed.
I had to change the configuration of WinKFP for fast baud rate to successfully flash. Seems like there are differences from ECU to ECU.
My update to the dynamic drive ECU required the fast baud rate to be disabled.

Thanks for the info man, might help some people with the same problem.

kennytent
06-04-2012, 06:12 PM
Great info, thanks for the effort, will be downloading asap.

Question though, have a '04 754li, and the stealership swears there is not a software update for the 745li's only the 750's.

A claim was made with PUMA (I think that's it), which the dealership said was a division of BMW, concerning drivability issues (going into 5th gear issues, sometimes starting in 2nd gear, etc) generally all the things that are supposed to be addressed with the "urban" updated software. They said tranny was bad, needed replaced for $9k, on a 41k mile car.

It seems the modern day dealership is a parts swap-er, and will not service and repair.

Just want to see if anyone has any input before trying this.

Thanks for your time.
Ken

bandit1730
07-08-2012, 05:18 PM
Here is an USA article (link at the bottom). Just need to keep pouring the NHTSA with complaints and safety issues. The more we document the issue, the more chances to get a recall (Hopefully a global recall. keep your fingers crossed)
pdated 2012-04-16 5:46 PM

NHTSA looking into serious issues with BMW's big 7-series luxury cars. Here's the Associated Press story:

U.S. safety regulators have found 16 crashes and five injuries in an eight-month investigation of transmission control problems with BMW 7-Series cars.
CAPTION
By Uwe Lein, AP

The National Highway Traffic Safety Administration began the probe in August and has now upgraded it to an engineering analysis, which is a step closer to a recall. However the cars have not been recalled.

The investigation covers nearly 122,000 BMWs from the 2002 through 2008 model years.

The cars have push-button start and electronic transmission controls. In some cases, the owners may think the cars are in park when they're actually in neutral. The safety agency said in documents on its website Monday that the cars can roll away unexpectedly and crash.

Messages seeking comment from BMW were not immediately returned on Monday.

NHTSA said in the documents that BMW and investigators have received 50 complaints about the problem.

In one case, the driver of a 2002 745Li told NHTSA that the car was parked at a day-care center north of Atlanta when it rolled about 40 yards and crashed into a parking lot embankment on March 29, 2010. No one was hurt.

In another complaint, a driver reported that he parked his 2006 750 model BMW on Feb. 21, 2007, and it was supposed to automatically shift to park when he touched the stop-start button to turn off the car. Instead, after the driver left the car, it rolled backward about 100 feet and crashed into a lamppost, the driver told NHTSA. No one was injured. He did not set the parking brake.

"The dealer stated they are unable to diagnose the failure," the man told NHTSA.

Federal safety regulators do not release the names of people who file complaints.

NHTSA said it upgraded the investigation to an engineering analysis "to further assess the potential safety consequences of the alleged defect."


http://content.usatoday.com/communities/driveon/post/2012/04/us-steps-up-probe-of-bmw-7-series-crashes/1#.T_oLEPWrGuQ

firemedic521
07-08-2012, 09:40 PM
Will this update benefit any year of the e65? I have a 2006 and don't have any harsh shift while slowing , 2-1. Occasionally if I step on it while doing 10-15mph the 2-1 downshift while under load feels harsh. I have everything in place to do the trans software update but want to know if this is good for all years or is it possible I will be rolling back my newer software.
Sent from my EVO using Bimmer App

bluzplayer
08-05-2012, 07:08 PM
Folks with Rapid Share files: Is there another way to download? I've had success only once in several attempts to download files from RS. The download of a 30Mb file takes over 12 hours (I have business class cable modem, and it works right, and 30Mb on other sites takes only moments reliably and routinely), and more often than not it stalls at about 95%, so another full day of waiting wasted.

I don't enjoy being coerced to pay a monthly fee to Rapidshare to download a public domain file, nor should any of us. Since Rapidshare claims there's no limit on downloads, I have to conclude that it's just a poor service instead of being intentionally limited to some arbitrary file size. There must be a better way??

rippjd
09-08-2012, 06:32 PM
Attached is a relevant SIB for those driving a 745i or 745iL.

I replaced my Guibo joint. After resetting the transmission adaption values, it took my car almost a week to smooth out the 2-1 downshift shift, although I'm not running the most recent transmission software.

flow19446
09-23-2012, 11:03 PM
Did anybody try this on their car yet and were you successful at do it if so can someone proved a DIY video or picture illustration on how to do it step by step for the dummies like me…lol thanks

bkc0508
09-25-2012, 12:27 PM
I am seeing this issue on a 06 750 that we bought a week ago. Seems to only happen when my wife is driving does not do it will me so much. I read too there is a updated pan and filter for this transmission is this the case too ?

bkc0508
10-03-2012, 05:03 PM
I am trying to work thru this.
I try this part
3. Open INPA>>choose chassis>>Transmission>>Gearbox Control module>>Identification (F2). now press arrow down on your keyboard and take note of your Assembly number. Close INPA

inpa both circles are black and have on beside them so i assume i am good. When i choose the g19 transmission i get the following error
Variant Checking
it has
Group file : D_EGS
SYS-0005: OBJECT FILE NOT FOUND
Program will be stopped!

cisco150
12-10-2012, 10:05 PM
Thanks for the diy i have completed this on my 02 745i and it drives a lot better, any other modules i should program or reset or is there a full update for all the modules or is it just the transmission one. I have a high idle on my car i check vacum leaks and everything checks out fine and had it smoked too. Thanks again for the diy and everyone on the forum because without this community the stealer would have are ass lol. Merry Christmas Everyone any Happy New Year

Piers1989
01-21-2013, 01:52 PM
I just tried this on my 745i.

Have some SERIOUS problems. I'm not new to using the BMW toolset and I'm an IT tech so I understand how stuff works generally speaking.

I tried this flash to update the gearbox in my car as I had been experiencing the hard 2-1 shift.

As it started updating I got the transmission warning on the dash (I assume is normal), and it started doing the flash. I waited as it went through, it hit 100% after about 4 mins.

It did not say succeed or completed, but popped up the same message (press ok to program 11 flashes remaining or similar - 1 less than before the start). I pressed okay on that one, the bar was still at 100% in the background but the status at the bottom of winkfp was "ready", but the program hung. I waited another 10 mins or so but nothing happened.

The car still says transmission failsafe gear cannot be displayed, and will not go into any gear.

INPA can no longer access the gearbox (saying something like it is responding but can't be recognised).

I can't flash it again with winKFP as it says the UID is incorrect (or similar).

I CAN connect to it with tool32 (have done reads only) and it is still responding, but a couple of the flash read options say the UID is incorrect.

I understand I can unbrick the ECU with tool32 but I don't know how, I've never used it before.

Can anyone help??

EDIT: FIXED IT AND SUCCESSFUL UPDATE.

Used tool32 to send a reset command after googling what the German things meant.

After this (still completely unusable) I was able to re launch winKFP and re flash the module.

took about 25 mins to do the flash this time :o (3-5 min hang, then slow flash over5 mins, then 3 min hang, then fast flash, then hang, then slow flash, then hang).

After this i had a load of errors on the DME DSC and SIM.

Cleared them all, and now its working :D

Will post an update if it fixed the problem tomorrow :)

CFL750Li
01-22-2013, 07:27 PM
This link returns a permissions error. Has the download moved? Thanks!


thanks mortyx10

SP-daten v 41 for e65 https://rapidshare.com/files/2644713914/E65_V41_Daten_Files.rar

file size 385mb

after decompress 1.29gb

latest update for e65 is v 41 so v 45 is the same as v 41

cisco150
01-22-2013, 09:08 PM
This link returns a permissions error. Has the download moved? Thanks!

i can post just need to know where and how i have it saved

cisco150
01-22-2013, 09:23 PM
This link returns a permissions error. Has the download moved? Thanks!

here is other link for you http://speedy.sh/RKZwg/E65-V41-Daten-Files-1.rar

or

http://speedy.sh/RKZwg/E65-V41-Daten-Files-1.rar or


<a href="http://speedy.sh/RKZwg/E65-V41-Daten-Files-1.rar">Download at SpeedyShare</a>

cisco150
01-22-2013, 09:26 PM
http://speedy.sh/RKZwg/E65-V41-Daten-Files-1.rar


<a href="http://speedy.sh/RKZwg/E65-V41-Daten-Files-1.rar">Download at SpeedyShare</a>





Click on this in the download page top right

Download: E65 V41 Daten Files (1).rar

See-5
01-25-2013, 01:29 AM
thanks for posting :D


Will it affect brake assist ?

which operates when for example you are crusing @ 60 mph and the gear change is on 6 and suddenly you applied hard braking ... the car will respond and down shifts quickly with you to bring the car to stop a lot faster



Do you feel that this future is now gone ? and is there any differnce in the gear-box behaviour other than the 2-1 problem ?


thank you

02QTR28
03-13-2013, 02:36 PM
Where can one acquire the wire? & on a scale of 1-10 what is the difficulty? Only reason I ask because planning on doing guibo / mechatronic sleeve & would love to also do this!

fratan
03-13-2013, 07:26 PM
I've been using Inpa and just changed my guibo joint. I decided to reset the adaptation values in Inpa to improve the 2-1 down shift and now I'm getting the transmission failure light. I check the error codes and getting a 4F89 Speed Trans. 3-4 , p17e8. I thought that resetting the adaptation would help but obviously I need to try and fix it. I've been reading that resetting your transmission adaptations isn't a good idea since there is information stored from the factory on the gears. I hope that I didn't just kill my transmission. Any ideas on what I should do next?

chowdarygm
03-24-2013, 04:26 PM
any idea why i am getting error when i am trying to enter assembly number

riff
05-02-2013, 06:29 AM
Hi Mortyx10

Any thoughts on where I might be able to get a DIY user guide for WINKFP? I'd like to use this tool but I would also like to do it without mucking up any modules.

Thanks for the help.

resistro
05-04-2013, 01:32 PM
I am a newbie when it comes to flashing. Got a 2003 745 with the harsh 2-1 downshift.

I think I got all the software I need installed to do the job but I don't know the steps to take. I have spent a lot of time reading the forums and I think I am going in sane trying to keep track. Could someone PLEASE write out the steps it would take to do this??

THANKS-ANYONE

Piers1989
05-04-2013, 01:34 PM
I am a newbie when it comes to flashing. Got a 2003 745 with the harsh 2-1 downshift.

I think I got all the software I need installed to do the job but I don't know the steps to take. I have spent a lot of time reading the forums and I think I am going in sane trying to keep track. Could someone PLEASE write out the steps it would take to do this and what software I need??

THANKS-ANYONE

Read the first post in this thread lol, its step by step instructions, with a detailed guide on getting winkfp setup too.

resistro
05-04-2013, 10:46 PM
Thanks for the reply. I actually think I am getting somewhere. Its about 1:30am and i been messing with this for hours now. tired.

I am running into 2 problems.

1) So when ran WinKFP it would not open. I read the attached word doc.... I tried to edit 'comment out' any 'long lines' in Sgidc.as2, but there was a bunch of them (shown below), so i removed the file completely from the gdaten folder. That made it run. Don't know if this would have an effect??

2) I get an error when I try to enter my ASSEMBLY number ('assembly identification number not found in the files determined by xxkconf.da2' ) so I cant find it when I try to choose it for the ECU family, ect. Is this because i blow out the Sgidc.as2 file completely?

I am using WinKFP 5.1.0 for an E65. could this have anything to do with it. I am so lost....
Everything went smooth when i loaded E65_41 Daten.


$L 3
$V PW
$G 1
$K ABS56 QY29AB0321c080eccfe4577b1cfb5deedb7ce36447aea7956c 808d0913877c203de6fdc28622fec9727678ec16996a762f2b fc20a3d097a87a552bb4b305ee34ce5a479d19c09937c66b98 161087b4696df170809c25051e3ea24beaa032b17468f1f843 cbead5bb94b405eac6a91fb4eec3444da0c2f7a0277fab4155 2322d96ee293f72e4510b6b1bbff794c
$K ACC260 LJ21AA02955c427547e39a88af53aeb67612f6177125ef80b2 0c4966c9c9ff341d6847116d78266efa678a7f7eed5f98acaa 5c569a54b97d65cf1214d7a678a978e0d771eb401aa8672d85 8cae3cfad77928ae79d7c3eb036ab93b741326803655c6943c 020de9f6998afabf13709cce73553a6a72fd70278359a1b93f 07c24342c83a519b3517b0549eabd352
$K ACC65 A721000068b9defb7d8b3e7eb10dd48a49f4cd79f2
$K ACCN60 HN21000068b9defb7d8b3e7eb10dd48a49f4cd79f2
$K ACSM2 NK01AB01217f891302922ad2bc38b0db942d8249e5a9e0872e 77240f5ca09f3eb8a266bbc0aa35aa23ac11534727335ffd4d 35e6e57e676480a5476eef570f85ee518c2e034d32caa3ddab 177e02c014086e0641fddd82660da6e6b071e44ab69e9d9abf 168432fbd39d0c7b7c7f90d2e9ad1316d3e7b10444487b4cce 253d50aed441f3a88250034f1f58cb33
$K ACSM60 MQ01AB0081cdef9d5ce5b3b47e16c44b481cd27e94849057ba c8b40844a44ce8ac28d2c6b20302dc082ef76d1ae1f7ca4440 16f8eeed0042f0091d11ad8209332ffebf687dfa3fffcfbf3f 9eea403d412a3f2d652be50ed418cd9b3a20e0c9c828173e82 58bd1216ddd910f1054cd40f74a406f3dd7ec208f081be255b 4cc5ace159890e1048142b87fecb7734
$K AFS260 MC16AA02026984cb30a1b43ed779be7059a47d277c749160f1 10af8c18eb51258d041ff9a1bbb53c918173b0f1458e931fc1 d1df9d17452eac75aa53d5e3ea14db6a73397c3a4037b64c95 ef0c94a3d0b10c03ee400a75b8430b7c21267aa8d93b266c8d 9e814741eb2beda7b006db990dcc15f6a8984564735f02b740 f9cab3ae4c92b8460441bfe8040045c3
$K AFS60 B716AA02026984cb30a1b43ed779be7059a47d277c749160f1 10af8c18eb51258d041ff9a1bbb53c918173b0f1458e931fc1 d1df9d17452eac75aa53d5e3ea14db6a73397c3a4037b64c95 ef0c94a3d0b10c03ee400a75b8430b7c21267aa8d93b266c8d 9e814741eb2beda7b006db990dcc15f6a8984564735f02b740 f9cab3ae4c92b8460441bfe8040045c3
$K AFS70 NM16AA02026984cb30a1b43ed779be7059a47d277c749160f1 10af8c18eb51258d041ff9a1bbb53c918173b0f1458e931fc1 d1df9d17452eac75aa53d5e3ea14db6a73397c3a4037b64c95 ef0c94a3d0b10c03ee400a75b8430b7c21267aa8d93b266c8d 9e814741eb2beda7b006db990dcc15f6a8984564735f02b740 f9cab3ae4c92b8460441bfe8040045c3
$K AFS90 KN16AA02026984cb30a1b43ed779be7059a47d277c749160f1 10af8c18eb51258d041ff9a1bbb53c918173b0f1458e931fc1 d1df9d17452eac75aa53d5e3ea14db6a73397c3a4037b64c95 ef0c94a3d0b10c03ee400a75b8430b7c21267aa8d93b266c8d 9e814741eb2beda7b006db990dcc15f6a8984564735f02b740 f9cab3ae4c92b8460441bfe8040045c3
$K AHM4R1 VP71AB043151f20c6d3d9949cc31882f1c9fe7141a7da375d3 053466fa8e56f3e4d66b79eb9bd5cb0ff6eb6faacc618f15f9 fef3b3a3810c1af142b04870470de15a1065c20c45205d915a bab6c8803b72feefe26bcfb74f6bac58c33362593a47c7dd73 24da33d878b155a04a480f550851caf1747183378a0a555f6b 37b0acd093493655f735e90dc7e61227
$K AHM65 A871000068b9defb7d8b3e7eb10dd48a49f4cd79f2
$K ALBV60 LU59AB0016bb992366a303eb5987798e2615f86ac4739caa8e 65e3683372c30441ec42a78dbc5d18d849bddcc5563c1da2d2 095164627cb88f3919a395d461e3d7e2e7ea6fcb371df57ae7 4e421aabe4d592029788d44ba24b13d4a3e82676e955a6bcef 07eda518bbb7dfcbff898c1cfe79a39e354c5af50398716030 d26f3e26b6a596bae94df111d71fd8d4
$K ALBV60 LU5AAB0016bb992366a303eb5987798e2615f86ac4739caa8e 65e3683372c30441ec42a78dbc5d18d849bddcc5563c1da2d2 095164627cb88f3919a395d461e3d7e2e7ea6fcb371df57ae7 4e421aabe4d592029788d44ba24b13d4a3e82676e955a6bcef 07eda518bbb7dfcbff898c1cfe79a39e354c5af50398716030 d26f3e26b6a596bae94df111d71fd8d4........many more lines

pfsupercar
07-18-2013, 08:50 AM
I've been using Inpa and just changed my guibo joint. I decided to reset the adaptation values in Inpa to improve the 2-1 down shift and now I'm getting the transmission failure light. I check the error codes and getting a 4F89 Speed Trans. 3-4 , p17e8. I thought that resetting the adaptation would help but obviously I need to try and fix it. I've been reading that resetting your transmission adaptations isn't a good idea since there is information stored from the factory on the gears. I hope that I didn't just kill my transmission. Any ideas on what I should do next?

I have experienced this same problem. After reseting the EGS adaptions I get the 3-4 error code 4F89 and the big slip during 3-4 shift. Have been trying to drive it away but no luck.
I have all the equipment. GT!, Iscan WT, Progman, etc. Its happened on 3 valve bodies now.

Any idea's appreciated.

fratan
07-18-2013, 03:34 PM
that 4f code is the bridge seal adapter between the mechatronics and tranny. That is a $7.00 part that goes. Reset the adaptation values again but next time drive it in manual and shift when the tacometer hits 2 rpm. Do you know how to shift it in M mode? The front buttons on the steering wheel is downshift and the back of the buttons is forward shift. Ride it in M mode for a day or so and it should be fixed after that. You didn't ruin your tranny. These are:thumbup: ZF transmissions which are considered the best that money can buy.

fratan
07-18-2013, 03:44 PM
If you still get the harsh downshifts after resetting the adaptation values then get the bridge seal adapter fix immediately. That's what I did. No more harsh downshifts, no more jerkiness, 123,000. We changed the bridge seal and tranny fluid in my 2006 750i and my wifes 2004 745i. We thought her tranny was dead because the car wouldn't go into gear. I would recommend not using winkfp unless your familiar with using inpa and have practice coding. Winkfp is flashing the computer and can be dangerous. I haven't even tried that yet and I'm highly skilled with computers.:thumbup:

mako1457
08-05-2013, 08:08 AM
This proceedure actually worked like a charm. I've been having erratic shifting for months now. 2006 E66, Changed tranny fluid...same problem... I was getting very frustrated until I read your post. WOW! Thanks again. Shifting has improved by 90%. Great post and such an easy fix.:)

Bud B
09-29-2013, 03:44 AM
Hi all,
I am new to these Forums and I am new to BMW.
I am really glad that I found people talking about the 2-1 jerky downshifting when stopping!
I have a 2006 BMW 530i and it does this same thing.
I took it to Lauderdale BMW and I have an appointment to have my transmission looked at but the service writer hinted at a new transmission.

I have since taken my car to a friends foreign car mechanic who hooked up his computer reader to my car and took it for a ride.
He came back and said it was normal and that when it jerked he could see the torque converter disengaging and that is what was causing the jerky downshift, which again was normal.
Through it all I knew that it was not!
I even told the mechanic that every American car comes to a full stop smoothly and with no lurch, why not BMW?
He told me it was a German Engineering thing, I said then the Germans did not design their cars very well!

Will the Software fix that is shown in this post also work on my '06 530i E60?

Other than the 2-1 my transmission shifts smooth and rides solid.
What's your thoughts and thanks in advance for any guidance you can add for me going forward.

I do not have a computer data cable or software, however I am rather proficient at computers, it is part of my Tech Job.
I'm sure that I could get what I needed and do this Software mod.
In the computer check list the car shows that the transmission had a transmission Data error in November of 2012 but nothing since..
The mechanic that hooked into the cars computer said that he did not see any errors and the car looked good.

Thanks,
Bud B

sogun
11-17-2013, 11:50 AM
I just tried this on my 745i.

Have some SERIOUS problems. I'm not new to using the BMW toolset and I'm an IT tech so I understand how stuff works generally speaking.

I tried this flash to update the gearbox in my car as I had been experiencing the hard 2-1 shift.

As it started updating I got the transmission warning on the dash (I assume is normal), and it started doing the flash. I waited as it went through, it hit 100% after about 4 mins.

It did not say succeed or completed, but popped up the same message (press ok to program 11 flashes remaining or similar - 1 less than before the start). I pressed okay on that one, the bar was still at 100% in the background but the status at the bottom of winkfp was "ready", but the program hung. I waited another 10 mins or so but nothing happened.

The car still says transmission failsafe gear cannot be displayed, and will not go into any gear.

INPA can no longer access the gearbox (saying something like it is responding but can't be recognised).

I can't flash it again with winKFP as it says the UID is incorrect (or similar).

I CAN connect to it with tool32 (have done reads only) and it is still responding, but a couple of the flash read options say the UID is incorrect.

I understand I can unbrick the ECU with tool32 but I don't know how, I've never used it before.

Can anyone help??

EDIT: FIXED IT AND SUCCESSFUL UPDATE.

Used tool32 to send a reset command after googling what the German things meant.

After this (still completely unusable) I was able to re launch winKFP and re flash the module.

took about 25 mins to do the flash this time :o (3-5 min hang, then slow flash over5 mins, then 3 min hang, then fast flash, then hang, then slow flash, then hang).

After this i had a load of errors on the DME DSC and SIM.

Cleared them all, and now its working :D

Will post an update if it fixed the problem tomorrow :)

Same thing happen with me today:cry:
Can you explain with more details how you resolve it?I try to use tool32 but with no success:dunno:

mwaku
04-15-2014, 06:16 AM
Does holding the acceleration pedal 'reset the adaptations' as similar to doing i through inpa?

I downloaded software "SP-Daten-V46.3" for my E60 and updated it myself using WinKFP and well basically pretty sure it updated, it only took like a few seconds to do so I'm unsure if it actually did it. But the cars software seemed to update, iDrive flashed a few times, a few errors came up and then disappeared.

Anyway went to go INPA and it wouldn't connect to the car, unsure why cause it was workin before *which is how i got the values to do the update from the gearbox*. so basically couldn't go in and reset my adaptations, and wondering if holding the pedal down for 30s does the same thing

drlava
08-03-2014, 10:25 AM
OP, thank you for this post, it was very helpful. I followed your instructions, and found that the assembly number for the update matched my current assembly number : 7552680
The info on my transmission is it's a 2004 model, and has 2005 software. I am using the V50.2 data and expected there to be an update available.
ECU family GKE214

I have read of E60 owners of years 2006+ getting software updates, so why does it appear that there is no software update available past 2005 on my 2004 E60 530i?

Also, ditto what mwaku asked above.