PDA

View Full Version : 2003 745Li - won't display on the i-drive screen when sensors are activated


First_745Li
06-12-2012, 06:50 PM
I recently had the battery replaced by an authorized repair center and had the battery registered with the onboard computer. When approaching an object in close range the parking sensor starts to sound but nothing is displayed on the screen. I was told by the dealer that only when the car is in reverse it would display on the i-drive screen. I recall it use to show regardless if it was in reverse or not. Anyone know in the car data section of the configuration screen how to configure this?

PAPER
06-12-2012, 09:11 PM
This might be way off , but have you tried hitting the PDC button next to the key ???

Sent from my GT-N7000 using Bimmer App

First_745Li
06-13-2012, 05:39 AM
This might be way off , but have you tried hitting the PDC button next to the key ???

Sent from my GT-N7000 using Bimmer App

Yes, the button is on (LED is on) and it does have the audible when getting close to an object, however, no visual.

samadkins29
06-13-2012, 09:41 AM
I recently had the battery replaced by an authorized repair center and had the battery registered with the onboard computer. When approaching an object in close range the parking sensor starts to sound but nothing is displayed on the screen. I was told by the dealer that only when the car is in reverse it would display on the i-drive screen. I recall it use to show regardless if it was in reverse or not. Anyone know in the car data section of the configuration screen how to configure this?

Somethings is wrong then. It should show when you drive forward. It should show ANYTIME you see the car on the idrive. However when going forward it will auto switch off after 10mph.

First_745Li
06-13-2012, 09:45 AM
Somethings is wrong then. It should show when you drive forward. It should show ANYTIME you see the car on the idrive. However when going forward it will auto switch off after 10mph.

The diagram of the car never shows up on the iDrive screen. Is there a setting in the iDrive configuration? Or is this something I need to have the dealer look at? :dunno:
They original told me it would only display when in reverse.

samadkins29
06-13-2012, 09:47 AM
No thats BS, lol take it back. I drive an 03 as well and mine always comes up. Unless you have an older software version or somethings, but that's unlikely.

dsaautocustomz
06-13-2012, 10:16 AM
Their is a setting in the idrive menu where you can switch the PDC visual off or on

canuckdon
06-13-2012, 10:21 AM
+1

First_745Li
06-13-2012, 10:31 AM
Their is a setting in the idrive menu where you can switch the PDC visual off or on

Dsa,
Can you tell me how to get to that setting? I'm a rookie when it comes to BMW.

dsaautocustomz
06-13-2012, 10:39 AM
Go into the settings view, in the vehicle column their should be a icon that says PDC Pic click and it should turn it on

samadkins29
06-13-2012, 10:50 AM
Learn something new everyday. Ima have to try that.

First_745Li
06-13-2012, 07:20 PM
Go into the settings view, in the vehicle column their should be a icon that says PDC Pic click and it should turn it on

Awesome! that worked...However, it seems that the PDC tunrs off after a couple of minutes. By this I mean the LED light on the PDC button goes off. I will keep an eye on it and let you guys know.

Keif
06-13-2012, 08:37 PM
It turns off automatically after you drive a certain number of feet (100' or 200' if I recall correctly) or go above a certain speed (12mph and 20mph stick out in my head).

First_745Li
06-13-2012, 09:06 PM
It turns off automatically after you drive a certain number of feet (100' or 200' if I recall correctly) or go above a certain speed (12mph and 20mph stick out in my head).

Keif,
Thank you. I assume that if I get near an object it will activate without any interaction from me? By this I mean, I wouldn't have to Manually press the PDC button to the ON position.

First_745Li
06-14-2012, 06:41 PM
Keif,
Thank you. I assume that if I get near an object it will activate without any interaction from me? By this I mean, I wouldn't have to Manually press the PDC button to the ON position.

Ok,
Problem solved. Thanks guys.