PDA

View Full Version : Coolant leak, engine hot!


Emeer18
06-18-2012, 11:56 AM
So i've been trying to diagnose this coolant issue for sometime now. My problem is, i assumed there was a coolant leak due to the fact that i've been having to add coolant once a month. I assumed it was the weephole. I couldnt find any coolant anywhere. Then my valve cover gasket developed a leak, thats been fixed engine runs perfect :) . And i havent had to add coolant in almost a month. I have never gotten any lights indicating the engine was to hot or anything like that either. Before i got the gasket fixed i would get the low coolant light but that was it. And to me it seems like this engine is running extremely hot. So i add some dye to the coolant and wait after a day of driving. I pull it in the garage and cant find any dye anywhere. But when i shined the UV light at the air filter housing i see a small splatter of coolant at the bottom of the housing. I tried to trace it but it led to nowhere. Im not to familiar with the coolant lines on this car. Any help and opinions would be greatly appreciated!

csmeance
06-18-2012, 12:23 PM
I would highly suggest checking the back of the engine block and look above the transmission bell housing, look for a coolant leak there. If you have a couple drops of coolant there then you have the valley pan leak. Not as involved as the weephole but it's still involved.

Also check the piping where the sensor (temp sensor) is located; I had a minor drip from there after getting the valley pan fixed.

Emeer18
06-18-2012, 02:14 PM
I would highly suggest checking the back of the engine block and look above the transmission bell housing, look for a coolant leak there. If you have a couple drops of coolant there then you have the valley pan leak. Not as involved as the weephole but it's still involved.

Also check the piping where the sensor (temp sensor) is located; I had a minor drip from there after getting the valley pan fixed.

Im just happy its not the weephole leak lol. Anything else cant be to bad. I'll be checking the valley pan for a leak asap. Where is the temp sensor located? Thanks for the help in advanced.

samadkins29
06-18-2012, 02:21 PM
temp sense is on the front of the engine with the water pump and belts.

Emeer18
06-21-2012, 05:03 AM
I checked everywhere, temp sensor is fine, no leaks from the overflow and the valley pan shows no signs of leaks or cracks. The coolant temperature on the dash ranges from 99-104 celsius. I recently got the valve cover gaskets replaced, it was leaking oil and replaced a few worn down vacuum limes. All i have to do now is replace the exhaust manifold gasket. None of this explains why i was losing coolant thou. I havent been losing anymore since i replaced the gasket and vacuum lines. Does anybody have a diagram of the entire coolant system?

Emeer18
06-23-2012, 04:59 PM
Finally found out what the leak was. The coolant return pipe that runs back to the water pump from the valley pan. Does anybody have the water pipe part numbers. Or a diagram for the coolant system with part numbers.

csmeance
06-23-2012, 07:04 PM
Finally found out what the leak was. The coolant return pipe that runs back to the water pump from the valley pan. Does anybody have the water pipe part numbers. Or a diagram for the coolant system with part numbers.

realoem.com, click the "click here" to acess the catalog, then type in the last 7 of your VIN in serial and you can go to see the exact coolant lines for your car!

Emeer18
08-10-2012, 05:56 AM
realoem.com, click the "click here" to acess the catalog, then type in the last 7 of your VIN in serial and you can go to see the exact coolant lines for your car!

Thanks for the info. Its a finished job now.

collins912
08-10-2012, 07:04 AM
I haven't seen it written anywhere. I am starting to wonder if the weep hole or any other leaks to this nature is due to the fact of not using the BMW coolant. Every pic posted with a coolant leak in the valley pan or in that general area has been green coolant. May very well the problem. Has anyone had this issue with the BMW blue coolant?