PDA

View Full Version : Car shuts off while driving...


Martir309
06-26-2012, 09:52 AM
I got a '07 525! 117k but most of the miles are highway miles, I'm in the military station at Kansas but I'm from new York so I drive home pretty often, , anyhow.. Like 2 weeks ago I was on my way back to Kansas, doing around 80mph when suddenly the car just shuts off and the check engine light came up.. I waited a couple of minutes and started back up again and continue to drive like 3 miles down the highway something happened again, same started it and drove off another 3 miles after shut off again, so this time I decided to wait about 30 minutes before starting it back up, after waited around I for about 30 mins I continued to drive down to Kansas without any problems,for about 200 more miles before I got back, although I noticed some kind of hesitation and lock of power when going uphill...oh yes the check engine light when away after a while.. I haven't got the car checked by a mechanic or nothing since I haven't gotten anymore problems since then.. But I'm afraid something is wrong with the car and I might do more damage to it if I keep driving it... Does anyone got anything idea what may be the problem..

burnie35
06-26-2012, 10:00 AM
First of all, thank you for your service! (I'm retired army from the Vietnam (1st ID) era, so I like saying that and hearing that.) I imagine you're at Fort Riley, home of the BRO.

Anyway, your profile says 535i, but the post says 525i. Since they have different engines, you probably should clarify so people can give appropriate answers.

Martir309
06-26-2012, 10:08 AM
Oh! Thanks a lot sir. I didn't noticed that,, is a 525!!..
Yes I'm station in ft Riley 1st ID. (2nd BDE)