PDA

View Full Version : BMW assist system Malfunction


rockygregs
06-28-2012, 11:31 AM
I had no bass in my car for a while so I decided to send my amp to IIya, I received my amp back yesterday and plugged it up but now nothing works... I am getting a BMW assist malfunction with a SOS symbol on the dash and a line going across it. I pushed the SOS button though and someone picked up.. I have disconnected and connected the TCU module and the Fibre Optic loop in the Glove compartment... I have even disconnected the cars battery and nothing still works... Please I would appreciate help from anyone who can tell me what to do.. I would hate to have to buy a new TCU module as I hardly even connect my phone to my cars bluetooth system.. Any help at all would be appreciated. Thanks...

gmcclintock
06-28-2012, 01:12 PM
you are pretty much stuck dude you will have to replace your TCU I've had the BMW Assist Malfunction on mine for at least a year now and I did everything you did I took it to the stealer and they said its a bad TCU and that it will cost me around $800 so I never got it replaced. But basically when you get the malfunction you need a new TCU the phone may still work as mine does but BMW Assist will not.

rockygregs
06-28-2012, 02:22 PM
Thanks for your response... I don't even care if the phone doesn't work, I just need my music to work and my radio. And why didn't you just buy one on eBay?

rockygregs
06-28-2012, 02:24 PM
And did you have to get the TCU programmed to the car?