PDA

View Full Version : car does not start spuradically


yunotknowing
06-30-2012, 03:41 PM
I just bought the car used from a BMW dealership locally and my aftermarket warranty has not kicked in yet. I insert the key, steering wheel moves into position, radio comes on and then I put my foot on the break and press the start button, nothing happens. This has happened to me twice before and I walk away for about 5 minutes and come back to the car and it starts right up.

I am not mechanically inclined so I donít know what things are called, so with that in mind, what do you guys/gals think my issue could be?

Car is a 2004 745Li with 112,000 miles. When it does start it runs perfectly.

Thanks in advance for your help.

yunotknowing
06-30-2012, 03:52 PM
OK, I dont know if this is associated with the car now cranking, but I was getting "parking break malfunction" and the key ejected twice on me. Third time was a charm, the car cranked and I was able to drive it around.

745on22s
06-30-2012, 06:26 PM
Look up Integrated power supply it should be the problem

yunotknowing
06-30-2012, 06:39 PM
Are these what you are talking about http://motors.shop.ebay.com/i.html?_nkw=Integrated+Supply

I plan on buying new, but wanted to get an idea of what it looks like.

Thanks for your help...

B7M4W5
06-30-2012, 07:00 PM
Ok so i had same problems and I have the same car 2004 E66, it turn out that i had the wrong battery from same type of stealer so i went to Sears and got the correct one

B7M4W5
06-30-2012, 07:04 PM
Here is the one u need
http://www.sears.com/shc/s/p_10153_12605_02850749000P?vName=Automotive&cName=Batteries&sName=&mv=cmp
Got this info from Paper.

stubbz
06-30-2012, 07:12 PM
I had the same problem with my 2004 745i and it was the Integrated power supply. I just went to the dealer for 120.00.

yunotknowing
06-30-2012, 08:43 PM
Thank you all for your replies. I am going to get both...as I am sure I have the original battery in this car...so a new would wouldnt hurt...

:)

Let you all know how it goes...

Rookie2008
07-01-2012, 12:02 AM
I have a NIB Integrated supply module if you like $90.00 shipped.

yunotknowing
07-02-2012, 05:48 PM
rookie, had I of checked my messages earlier I would have taken that offer as it would have saved me $30. I purchased one early this morning at my dealership and swapped it out already. Wasnt to hard to do...surprisingly enough.

I will update you all if this has resolved my issue.