PDA

View Full Version : 2004 530i Sport - Dynamic Drive Malfunction. Has anyone else experienced this?


acribb
07-12-2012, 11:52 AM
2004 530i Sport with 121K miles - Dynamic Drive Malfunction. The issue pops up at random times and always goes away with a shutdown and restart. It does seem to occur now when I go over bumps lately. Right before the Dynamic Drive Malfunction error occurs, the radio cuts off briefly. Has anyone else experienced this? If so, what was the resolution and cost? I can sometimes feel something mechanical going on in the front when this error occurs. Maybe a slight thump of something moving. The sway bar maybe?

I have read various causes of this Dynamic Drive Malfunction on the interwebs-

1. Alternator or battery. I just had the battery replaced a few months ago, so that's new. The alternator and battery were replaced at 70K. I guess it could be the alternator, but I figured I would have more errors occurring in iDrive than just the singe Dynamic Drive Malfunction. The last time the alternator went out, everything was wacky and I received all kinds of error messages.

2. Steering angle sensor- I guess it could be this, but I believe that was replaced under warranty at < 50K miles.

3. CHF fluid (BMW's power steering fluid) is low. I checked and mine was a little low. I topped it off but I still get the Dynamic Drive Malfunction error every 2 to 3 days.

Thanks for any input on this matter that I can take to the dealer so that I will get raped as minimally as possible!