PDA

View Full Version : Service Engine Light doesn't show on Engine start (550i 2008)


aungmaw
07-18-2012, 04:16 PM
I just got 550i 2008 sport package and all going really well. Is it normal that Service Engine Light doesn't show during first few seconds when starting an engine on this model? I had 2002 330i and normally Service Engine Light would appear when I turn the keys and go way after the engine had fully started. This way at least I know that Service Engine Light is working. On 550i will it show only when there is really a problem?? Thanks so much in advance!!

suthtow
07-18-2012, 04:51 PM
Key on engine off check engine light on.
Key on engine on check engine light of if all is well.
If you have no light at all, you need to see if the led has been cut out, seen that that's why I say that. If so time to buy cluster.

Sent from my C771 using Bimmer App

aungmaw
07-18-2012, 05:34 PM
Thank you for your reply. Please let me know where to check the led? Do you know how much a Cluster cost? Thanks.

1bad540
07-18-2012, 05:45 PM
Sounds like some old ghetto car lot tricks

aungmaw
07-18-2012, 05:59 PM
@1bad540, Not so sure what you are trying to say here..

suthtow
07-18-2012, 06:04 PM
Means if check engine light is on and its expensive to repair. Removed the light.
You would have to remove the cluster, and remove the cover see if there is black tape where the cel is or if the led is cut out.

Sent from my C771 using Bimmer App

l1tech
07-18-2012, 06:13 PM
Sounds like some old ghetto car lot tricks

Seen alot of car dealers do this so that the potential buyer doesn't think there is a problem with the car.

borderchris
07-18-2012, 08:51 PM
@1bad540, Not so sure what you are trying to say here..

Car lot in the ghetto.

Sleazeball working at car lot in the ghetto.

Sleazeball with soldering iron. Sleazeball de-soldering the PCB connections to the SES light.

This guy selling you the car:

http://4.bp.blogspot.com/_M_YumU0hIWU/Sw2GoiFOcII/AAAAAAAAAH8/sYOwAHpGbho/s1600/used_car_salesman.jpg

C'mon, man. Really? Have a sense of humor.

aungmaw
07-18-2012, 11:35 PM
Thank you all for the comments. I just want to be sure this is for 2008 550i. Look at this video on Cluster test and SES light never came. http://www.youtube.com/watch?feature=endscreen&v=zHN4kz1cnhQ&NR=1

Campfamily
07-19-2012, 06:29 AM
When I start my car, nothing comes up that says Service Engine Soon, or SES. However, the light that I believe indicates Check Engine comes on briefly. The light is located directly above the flat tire warning indicator in the cluster. Car is a 2008 550 with Comfort Access.

aungmaw
07-19-2012, 08:02 AM
@campfamily Well then it does not seem to be an SES issue. I saw youtube videos and some 5 series shows SES on start, but some really doesn't show. I guess it must be on specific models (or) software versions. In my case Flat Tire Warning doesn't even show.

aungmaw
07-19-2012, 08:05 AM
When I start my car, nothing comes up that says Service Engine Soon, or SES. However, the light that I believe indicates Check Engine comes on briefly. The light is located directly above the flat tire warning indicator in the cluster. Car is a 2008 550 with Comfort Access.

@Campfamily, What is the exact message you see if not SES? I hope it is not some sort of a sign?

Campfamily
07-19-2012, 09:17 AM
@Campfamily, What is the exact message you see if not SES? I hope it is not some sort of a sign?

I will take a video of the dash from my mobile phone later today (might be this evening) and post it for you to watch.

Campfamily
07-19-2012, 12:13 PM
OP, don't know how to upload a video file to the board, PM me your email address and I'll email it to you.

Keith

aungmaw
07-19-2012, 06:01 PM
All right, Many thanks to Campfamily for sending me a video and clearly SES will not come on start on 2008 550i models. So no soldering, no getto, no tricks @borderchris, @1bad540? I think SES will show on some 5 series models. Now I'm glad...

l1tech
07-19-2012, 06:14 PM
It is federal law that the check engine light comes on when the ignition is cycled to the on position, this applies to every car in the United States regardless of make or model. If you have CAS, without putting your foot on the brake push the start button once, the check engine light should illuminate. If you don't have CAS, put the key fob in and then without stepping on the brake push the start button once, the check engine light should illuminate. Like I said this is mandated by the federal government and is an emissions requirement regardless if your state requires emission testing or not. If your check engine light does not illuminate then you have problems.

aungmaw
07-19-2012, 06:32 PM
@l1tech, Do you know where exactly is SES light in BMW 2008 550i? You comment is well taken but it appears to be then that many of the 2008 550i owners LED's were cut/soldered according to borderchris and 1bad540. SES on Campfamily didn't come either.

suthtow
07-19-2012, 06:46 PM
Your ses light or check engine light is the picture of the engine. Top center right. No actual letters like earlier models

Sent from my C771 using Bimmer App

l1tech
07-19-2012, 06:52 PM
The check engine light, which is actually a symbol of an engine, is directly above the tpms indicator and directly to the left of the airbag light. I believe it is the 3rd light from the right on the top row.

aungmaw
07-19-2012, 07:18 PM
@l1tech, @suthtow, @Campfamily: Now I figured. I see a "engine symbol" come and go so SES light is clearly working. I was actually look for "Service Engine Soon" text like in the old models which made me go Nuts. Thanks you guys, you are all great!!