PDA

View Full Version : coolant leak


wymo
09-13-2012, 10:38 AM
why is my 03' 745Li leaking antifreeze and where is it leaking from?

bossku69
09-13-2012, 12:38 PM
Mine does the same thing in an '06 750Li. Dealer said they can not locate the leak but could be through a small crack or clamp. They will need to run a flush test to find it which will cost me $$$. I'll just keep putting in coolant every few weeks instead

sirstopher
09-13-2012, 12:58 PM
Hoses, clamp, water pump, expansion tank, crossover pipe, valley pan, radiator. Ect, ect...

Be a little more descriptive!

sirstopher
09-13-2012, 01:00 PM
Mine does the same thing in an '06 750Li. Dealer said they can not locate the leak but could be through a small crack or clamp. They will need to run a flush test to find it which will cost me $$$. I'll just keep putting in coolant every few weeks instead

Any good mechanic can pressure test the system for 40 bucks and tell you without a flush.

fabolousarch
09-13-2012, 02:56 PM
I'm having the same problem and I dont have a leak... I smell the antifreeze fumes when I'm driving with the windows down and I get the low coolant warning as well. This is really worrying me ... Someone please help

SFbay
09-13-2012, 07:17 PM
Check wheep hole- most invisible leak
Lower hose sensor
Expansion tank
Y shape hose from heads

Marcusmenu
09-25-2012, 03:53 PM
Had the same problem, it was the expansion tank. Dont buy the after market ones, you will have the same problem within a few weeks plus the hoses sometimes don't fit exactly tight and will leak.

I suggest you get it fron the dealer for less than $125.00. Changing it is simple, should take only a few min. You will loose some coolant and make sure you have extra on hand or just refill with water.

Hope this help.

Marcusmenu
09-25-2012, 04:01 PM
I'm having problem with my trunk opening and closing automtically. I can hear the motor running when the button is activated but the trunk will not fully open or close.

Have anyone else had this problem and is this something I can fix myself. Dont' want to know what the stealership would charge.

If it's too big of a problem I'm thinking of leaving it alone and continue to do it manually, just like for everything to work on my ride.

Help anyone.


Thanks

Emeer18
09-25-2012, 11:10 PM
I recently had the coolant problem. I thought it was the weephole, thank god it wasnt. My expansion tank was fine as was the radator and hoses. Check your water pump! The part of the water pump that connects to the belt can sever from the pump and only at high rpm's does it spin fast enough to leak. If you DIY should take 3-5 hours and about $250-300. If not 750 at the dealer.

Emeer18
09-25-2012, 11:13 PM
I'm having problem with my trunk opening and closing automtically. I can hear the motor running when the button is activated but the trunk will not fully open or close.

Have anyone else had this problem and is this something I can fix myself. Dont' want to know what the stealership would charge.

If it's too big of a problem I'm thinking of leaving it alone and continue to do it manually, just like for everything to work on my ride.

Help anyone.


Thanks

Look for a thread on here that talks about auto trunk pump fluid. It may be low on fluid and hence not enough pressure to open that heavy trunk lid