PDA

View Full Version : E66 760Li, doing AGA coolant pipe and WP, all hoses today


mws
09-14-2012, 11:16 AM
already started waterpump job, got a look at the weephole, and actually, it's not leaking, but... the seal in the timing cover for the front of the pipe is rock-hard, and the engine has 130K on it. It's time.

I decided to stop work and order the All German Auto parts. Diving into it right now.

On the 12-cyl you have to have the WP off, to twist and tighten the tube. The valley is too tight to do it by hand. They give you a special tool to rotate the tube, and it has to be rotated through the hole, with the WP off. The V8 has enough room to tighten it by hand in the valley.

Also, pretty much every single hose in the engine bay was leaking, so they are all being replaced. I even sprayed them down and watched for leaks and confirmed they were all weeping and spweing from their clamp-joints.

mws
02-12-2013, 03:04 PM
already started waterpump job, got a look at the weephole, and actually, it's not leaking, but... the seal in the timing cover for the front of the pipe is rock-hard, and the engine has 130K on it. It's time.

I decided to stop work and order the All German Auto parts. Diving into it right now.

On the 12-cyl you have to have the WP off, to twist and tighten the tube. The valley is too tight to do it by hand. They give you a special tool to rotate the tube, and it has to be rotated through the hole, with the WP off. The V8 has enough room to tighten it by hand in the valley.

Also, pretty much every single hose in the engine bay was leaking, so they are all being replaced. I even sprayed them down and watched for leaks and confirmed they were all weeping and spweing from their clamp-joints.

decided it was too much work and probing the weep-hole showed no coolant in the valley.